Last Comment Bug 265985 - Form auto-fill overwrites existing information - can't disable?
: Form auto-fill overwrites existing information - can't disable?
Status: RESOLVED DUPLICATE of bug 229762
:
Product: Toolkit
Classification: Components
Component: Form Manager (show other bugs)
: Trunk
: x86 Windows XP
: -- major with 7 votes (vote)
: ---
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
:
Mentors:
: 304252 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 09:19 PDT by jafa
Modified: 2008-07-31 04:30 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description jafa 2004-10-25 09:19:26 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Auto-filling forms is a good feature, except when you are editing someone elses
profile from a web admin page.

If I edit an account "foo" in a phpBB forum then the username field gets
automatically overwritten by my username even though the field already contained
a value (in this example "foo").

Under options I have disabled "Save form information" and cleared it but it is
still filling in the username field with my username.

I have probably missed the option to disable the auto-form feature, however if a
form is already filled in then I don't think the auto-filler should replace
values in the form.

Unfortunatly this means that I have to use IE for all admin pages :(

Nick

Reproducible: Always
Steps to Reproduce:
1. Go to admin page on a phpBB site.
2. Edit a user profile (not your own).


Actual Results:  
The user name shown was replaced by my own username, even though it was someone
elses profile with their other details.

Expected Results:  
The username should have the value returned from the website.
Ie it should not be overwritten.

Under options I have disabled "Save form information" and cleared it but it is
still filling in the username field with my username.
Comment 1 Christian :Biesinger (don't email me, ping me on IRC) 2004-10-25 09:22:52 PDT
-> firefox (which has a different form manager implementation than mozilla)
Comment 2 Ben Rubinstein 2004-10-27 11:41:14 PDT
Yep, this is a real PITA - I've just registed with Buzilla precisely to report this one.  It's taken me several 
days to realise that this was Firefox causing the problem; I've twice been blocked from logging into a 
critical internal system because, it turned out, my username had accidentally been duplicated - a 
consequence, of course, of this bug.
Comment 3 Jack Kan 2004-11-21 03:00:24 PST
This is a huge bug.  Imagine people accidentally logging in on your account just
because you had only one saved user/pass and it was filled in.

Also, when you are updating information, FF automatically fills things in even
if there is a default text or password specified.  This is annoying especially
with password fields since you can't even see that it has been changed.

Have an option for turning off autofill at least!
Comment 4 Jack Kan 2004-11-21 03:01:51 PST
This is a huge bug.  Imagine people accidentally logging in on your account just
because you had only one saved user/pass and it was filled in.

Also, when you are updating information, FF automatically fills things in even
if there is a default text or password specified.  This is annoying especially
with password fields since you can't even see that it has been changed.

Have an option for turning off autofill at least!
Comment 5 Adam Guthrie 2005-08-11 00:37:06 PDT
*** Bug 304252 has been marked as a duplicate of this bug. ***
Comment 6 Phil Ringnalda (:philor) 2005-09-15 00:33:17 PDT
Wups, what's this doing over here? Actually replacing a value in a username
field isn't Form Manager, which is the dropdown that offers to autocomplete when
you start typing in something like Google's search box, it's Password Manager,
and this is a dup of (the messed up and reopened part of) bug 229762.

*** This bug has been marked as a duplicate of 229762 ***

Note You need to log in before you can comment on or make changes to this bug.