character set wrongly assumed when surfing (german Umlaute displayed as "?")

RESOLVED DUPLICATE of bug 227631

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 227631
13 years ago
13 years ago

People

(Reporter: phil69, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

When surfing from one site to another, Firefox (wrongly) assumes, the character
set of all succeeding pages will stay the same. For example, opening from a
result in google (using unicode) to a page coded in 'Western', the browser still
decodes using unicode. The result: all special characters (french accents,
german Umlaute ä,ö,ü) are displayed as "?". Directly accessing the page works
fine, but this is not the way, most people use a search engine...

The problem is known since months and occurs in Mozilla as well. Unfortunately
this issue is not given a high priority :-(

1) Why is the assumption made, that all (succeeding) pages are coded the same?
2) Why can't Firefox after realizing, that something is wrong (by displaying
"?"'s), try to use a different character encoding table?

Regards, Philipp


Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago
Are you sure that the succeeding pages have a charset specified? (as META tag in
source or as HTTP header, for the latter use http://web-sniffer.net/).

related: Bug 255241 and Bug 158285

Comment 2

13 years ago
Per private email from reporter I can confirm that this affects only pages
without any charset encoding. So it seems to be a duplicate of bug 158285.
Please resolve it.

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 227631 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.