If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

parent window isn't movable / draggable when sheet is open

RESOLVED FIXED

Status

Core Graveyard
Widget: Mac
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: David Catmull, Assigned: Ari)

Tracking

({regression, verified1.8})

Trunk
PowerPC
Mac OS X
regression, verified1.8
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.76 KB, patch
Mark Mentovai
: review+
Simon Fraser
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

When a sheet is open, such as an error alert, the about box, or the preferences
window, the parent window is not draggable.

Reproducible: Always
Steps to Reproduce:
1. Have a browser window open
2. Select About Mozilla Firefox or Preferences from the application menu
3. Try to drag the browser window

Actual Results:  
It beeps.

Expected Results:  
The window should be draggable; that's a basic part of how sheets are supposed
to work.
Looks as we don't have an older report, confirmed.
Assignee: bugs → jag
Status: UNCONFIRMED → NEW
Component: OS Integration → XP Toolkit/Widgets
Ever confirmed: true
Product: Firefox → Browser
QA Contact: firefox.os-integration → jrgmorrison
Whiteboard: DUPEME
Version: unspecified → Trunk

Comment 2

13 years ago
*** Bug 276425 has been marked as a duplicate of this bug. ***
Assignee: jag → sfraser_bugs
Component: XP Toolkit/Widgets → Widget: Mac
QA Contact: jrgmorrison
Summary: Window not draggable when sheet is open → parent window isn't movable / draggable when sheet is open
Whiteboard: DUPEME
(Assignee)

Comment 3

13 years ago
Created attachment 170620 [details] [diff] [review]
potential patch

This seems to fix it. I haven't noticed any ill effects. Does anyone know the
justification for the check that I removed?
Attachment #170620 - Flags: review?(sfraser_bugs)

Comment 4

13 years ago
CVS blame:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/widget/src/mac/nsMacMessagePump.cpp

says that change was made to fix bug 126786.
(Assignee)

Comment 5

13 years ago
OK, now I think I know what's going on:

The check was added in bug 126786, but was not meant to apply to OS X. In fact, the original check 
was: 

+        if (nsToolkit::OnMacOSX() ||
+            !topWidget || NS_FAILED(topWidget->IsEnabled(&enabled)) || enabled ||
+            (anEvent.modifiers & cmdKey)) {

See comments 9 and 10 in bug 126786.

But then, the patch for bug 223545 removed the "nsToolkit::OnMacOSX()". Since that bug doesn't seem 
to have anything to do with dragging, but did replace nsToolkit::OnMacOSX() with nsToolkit::
OSXVersion(), I think this is an accidental regression. Since OS9 is dead, we can probably just remove 
the whole check.

Updated

13 years ago
Assignee: sfraser_bugs → joshmoz

Comment 6

12 years ago
This is a serious bug that is super annoying, and can cause FF to get into a
locked state if window layering changes while a sheet is up and FF is in the
background.
Flags: blocking1.8b5?

Comment 7

12 years ago
Comment on attachment 170620 [details] [diff] [review]
potential patch

This is the right thing to do.	r=me, as long as the indentation is fixed to
reflect that ::DragWindow and friends have moved up a level.

Here's the regression, where it went wrong:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&r
oot=/cvsroot&subdir=mozilla/widget/src/mac&command=DIFF_FRAMESET&file=nsMacMess
agePump.cpp&rev2=1.143&rev1=1.142
Attachment #170620 - Flags: superreview?(sfraser_bugs)
Attachment #170620 - Flags: review?(sfraser_bugs)
Attachment #170620 - Flags: review+

Comment 8

12 years ago
Comment on attachment 170620 [details] [diff] [review]
potential patch

Thanks for the archaeology.
Attachment #170620 - Flags: superreview?(sfraser_bugs) → superreview+
Assignee: joshmoz → the_great_spam_bin

Updated

12 years ago
Attachment #170620 - Flags: approval1.8b5?

Comment 9

12 years ago
Fixed on the trunk.  This is a regression, though it regressed before 1.7/aviary
1.0 - let's get this for the branch too if we can.  Low risk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: regression
Resolution: --- → FIXED

Comment 10

12 years ago
I recommend taking this on the branch.

Updated

12 years ago
Attachment #170620 - Flags: approval1.8b5? → approval1.8b5+
Checking in nsMacMessagePump.cpp;
/cvsroot/mozilla/widget/src/mac/nsMacMessagePump.cpp,v  <--  nsMacMessagePump.cpp
new revision: 1.148.8.1; previous revision: 1.148
done
Keywords: fixed1.8
Blocks: 290389

Comment 12

12 years ago
belatedly setting the blocking 1.8b5 flag since we took this fix on the branch.
Flags: blocking1.8b5? → blocking1.8b5+
Keywords: fixed1.8 → verified1.8

Updated

8 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.