"A News (NNTP) error occured: Aborted by user" when trying to access news server with authentication

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: mcsmurf, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

Trunk
x86
Windows 2000
fixed-aviary1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
To reproduce first get a current trunk build. Then create a news account, which
requires authentication. Now save the username/password (maybe this is optional,
the bug also seems to occour when not saving username/password), restart Mozilla
and try to access this news account. Every action (expanding newsgroup tree,
trying to read posting, get read count, etc.) brings up the error "A News (NNTP)
error occured: Aborted by user". Maybe this Bug has the same cause as Bug 267461.
(Reporter)

Comment 1

14 years ago
This bug here will be fixed as soon as Bug 267367 will be baked out on trunk
and/or MailNews be fixed.
(Reporter)

Comment 2

14 years ago
That patch has been backed out and so fixed this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: MailNews → Core

Comment 3

14 years ago
Looks like this bug is back in recent builds of Thunderbird.  I can confirm that
it happens in version 1.0RC1RC1 (20041130).  Please reopen this bug and fix
before the 1.0 release!
(Assignee)

Comment 4

14 years ago
can anyone else confirm this is in the rc1 build?
Status: RESOLVED → UNCONFIRMED
Flags: blocking-aviary1.0?
Resolution: FIXED → ---

Comment 5

14 years ago
Sorry, I forgot to include this link in my previous comment:

http://forums.mozillazine.org/viewtopic.php?t=174745

Comment 6

14 years ago
To confirm/reproduce this bug, simply create a news account in a recent
Thunderbird branch build, such as 1.0RC1 (20041201).  You must use a news server
that requires authentication, such as newsgroups.bellsouth.net or
news.supernews.com.  (It doesn't matter whether or not you have an account on
the news server, since this bug occurs prior to authentication.)  Then try
connecting to that account to download a list of newsgroups.  You will likely
get the error:  "A News (NNTP) error occurred: Aborted by user".
(Assignee)

Comment 7

14 years ago
yes, you're right...
Assignee: sspitzer → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 8

14 years ago
Created attachment 167564 [details] [diff] [review]
proposed fix
(Assignee)

Comment 9

14 years ago
Comment on attachment 167564 [details] [diff] [review]
proposed fix

this fixes it, thx, Scott...
Attachment #167564 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #167564 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 10

14 years ago
fixed trunk and branch, and seamonkey.
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Verified with Windows TB build 2004-12-02-11-0.9
Status: RESOLVED → VERIFIED

Comment 12

14 years ago
Confirmed fixed in nightly build post-1.0RC1 (20041202).

Thanks David!

Comment 13

14 years ago
I see no such build in
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/. Any other URL?
(Assignee)

Comment 14

14 years ago
*** Bug 273081 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking-aviary1.0?
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.