fieldset border lines do not redraw to offset legend element

RESOLVED DUPLICATE of bug 247068

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 247068
14 years ago
14 years ago

People

(Reporter: john russell, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

if the legend occurs in other than the default position, the borders
provided by fieldset are not drawn correctly. 

Reproducible: Always
Steps to Reproduce:
1. access the above url
2. view the form that calculates bmi
3.
Actual Results:  
note the upper left border line doesnt get to legend box


Expected Results:  
border should have been drawn to box

surprised that something this basic trickled thru
all the testing...  sure makes for poor looking forms.
other browsers cope well ;-[
(Reporter)

Comment 1

14 years ago
note that this was tested with the firefox RC2 
just checked with mozilla nightlies and it is repaired 
there ...  i guess firefox not using mozilla stuff done
in last few months ... ;-[  ;-[  ;-[ 

Comment 2

14 years ago
John did you report bug 247068?
(Reporter)

Comment 3

14 years ago
yes -- that is the one from back in june and it
was repaired for mozilla ok ... i launched the 
new report as they were asking for comments on
firfox rc2  and i was amazed it didnt include
 that old fix..... 

Comment 4

14 years ago
These are the css rules applying to the framed page:
fieldset {margin:4px; border:1px solid black; padding:2px}
legend {margin-left:10px; background:thistle; border: black 1pt solid;
        padding-left:4px; padding-right:4px}
Note the margin-left:10px applied to legend.
If there is a layout bug here, it is a minor one.

Using Mozilla 1.8a5 build 2004110305 and Firefox 1.0 RC2 rv: 1.7.5 build
20041103 under XP Pro SP2.
> and i was amazed it didnt include that old fix..... 

Firefox 1.0 is based on Mozilla code from the end of March 2004.  Bug 247068 was
fixed in July 2004.  So the fix for that bug is not in fact in Firefox 1.0. 
It'll be in Firefox 1.1.

So the point is, don't bother reporting layout bugs in Firefox 1.0 unless they
appear in a trunk build as well.

*** This bug has been marked as a duplicate of 247068 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Not to mention that you reported this against Firefox a month ago and were told
the same exact thing then.... (bug 263001).
You need to log in before you can comment on or make changes to this bug.