Grouped By Sort fails when last message in group is removed

RESOLVED DUPLICATE of bug 268969

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 268969
14 years ago
14 years ago

People

(Reporter: Scott Davis, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Thunderbird version 0.9 (20041103)

When the last message in a group is removed (delete, move to folder, relabel if
grouping by label...), the message list fails horribly. The list view will often
stop responding to clicks and will go blank - list of emails gone - until you
resort by clicking on a sort header.

Reproducible: Always
Steps to Reproduce:
1. Group by whatever column you like
2. Find a group with only one message.
3. Delete or move the final message in the group
4. Click within the message list to highlight another message
Actual Results:  
Message list does not respond. Click again and the message list will disappear.

Expected Results:  
Redraw message list with un-used group removed

*** This bug has been marked as a duplicate of 268969 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.