Closed Bug 268818 Opened 20 years ago Closed 20 years ago

Description of "Alt-Enter" functionality missing from help

Categories

(Firefox Graveyard :: Help Documentation, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gemenge, Assigned: jwalden+fxhelp)

Details

Attachments

(1 file, 4 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

In the help there is nowhere a reference that "Alt-Enter" opens a new tab from
the address in the address location field. This should be documented in the
"tabbed browsing" section of the help "Using Tabs/Creating and Loading Tabs".

Reproducible: Always
Steps to Reproduce:
1. open help
2. serch for "tabbed"
3. open the third entry "Using Tabs"


Actual Results:  
There is the following documentation. I have the German version which I include
here anyway. I try to translate it to English:

"If you want to open a link in a new tab you can accomplish this in several
different ways:

    * Click on the link with the middle mouse button
    * Hold the Strg key and click the link
    * Drag the link to an empty place in tab bar
    * Drag the link to an existing tab to show the new page in this tab.
    * Right-click on the link and choose "Open link in new tab" from the context
menu."

In German:

"Möchten Sie einen Link in einen neuen Tab laden, können Sie dies auf mehrere
Arten erreichen:

    * Klicken Sie den Link mit der mittleren Maustaste an. (Sollten Sie ein
Mausrad an Ihrer Maus besitzen, ist ein Klick mit dem Mausrad gleichbedeutend
mit dem Klick der mittleren Taste.)
    * Halten Sie StrgBefehlstaste und klicken Sie auf den Link.
    * Ziehen Sie den Link per "Drag and drop" auf einen leeren Platz in der Tab
Leiste. (Unter Umständen ist die Tab Leiste nicht sichtbar, wenn Sie nur eine
Webseite geladen haben. Sehen Sie bitte unter Anpassen der Tabs nach, wie dieses
Verhalten geändert werden kann.)
    * Ziehen Sie den Link per "Drag and drop" in einen bestehenden Tab, um die
Seite in diesem Tab zu laden.
    * Rechtsklick auf den Link und wählen Sie Link in neuem Tab öffnen aus dem
Kontextmenü."

Expected Results:  
I would expect the following:

"If you want to open a link in a new tab you can accomplish this in several
different ways:

    * Click on the link with the middle mouse button
    * Hold the Strg key and click the link
    * Drag the link to an empty place in tab bar
    * Drag the link to an existing tab to show the new page in this tab.
    * Right-click on the link and choose "Open link in new tab" from the context
menu.

If you want to open an URL in the address field in a new tab enter the URL in
the address field and press Alt-Enter"

In German:
Möchten Sie einen Link in einen neuen Tab laden, können Sie dies auf mehrere
Arten erreichen:

    * Klicken Sie den Link mit der mittleren Maustaste an. (Sollten Sie ein
Mausrad an Ihrer Maus besitzen, ist ein Klick mit dem Mausrad gleichbedeutend
mit dem Klick der mittleren Taste.)
    * Halten Sie StrgBefehlstaste und klicken Sie auf den Link.
    * Ziehen Sie den Link per "Drag and drop" auf einen leeren Platz in der Tab
Leiste. (Unter Umständen ist die Tab Leiste nicht sichtbar, wenn Sie nur eine
Webseite geladen haben. Sehen Sie bitte unter Anpassen der Tabs nach, wie dieses
Verhalten geändert werden kann.)
    * Ziehen Sie den Link per "Drag and drop" in einen bestehenden Tab, um die
Seite in diesem Tab zu laden.
    * Rechtsklick auf den Link und wählen Sie Link in neuem Tab öffnen aus dem
Kontextmenü.

Wenn Sie eine Adresse aus dem Adressfeld in einem neuen Tab öffnen wollen, dann
geben Sie die Adresse in das Adressfeld ein und drücken dann Alt-Enter."
This is a Firefox help doc issue: --> Firefox:Help doc
Product: Documentation → Firefox
sorry...
Assignee: documentation → jwalden+fxhelp
Component: Help Viewer → Help Documentation
QA Contact: daniel.bugmail → firefox.help-documentation
A patch made
Comment on attachment 177432 [details] [diff] [review]
Patch, including description of alt-enter

Huh, why is the whole file being changed?

And the text should be more like this:
<p>To open an URL in the Location Bar in a new tab, enter the URL in the
Location Bar and press &altKey;+&enterKey;.</p>
Attachment #177432 - Flags: review-
Ok. I will, I think everything is all changed because I fail at making
.diff/.patches. I'll try agian.
Attached patch a better patch (obsolete) — Splinter Review
For some reason the diff utlity is showing that the entire file is being
changed even though I added a line. I don't know why. This patch follows
steffen wilberg's suggestion.
Attachment #177432 - Attachment is obsolete: true
Attachment #177552 - Flags: review?(steffen.wilberg)
(In reply to comment #6)
> For some reason the diff utlity is showing that the entire file is being
> changed even though I added a line.

Your source tree is stored with Windows line endings.  When you installed Cygwin
you must have chosen the Windows line endings option, which means CVS pulled the
source tree and converted it to Windows line endings on the fly.  You can
probably work around this if you re-save the file with Unix line endings using a
suitable text editor, but in the long term you should rerun the Cygwin installer
with the correct line endings option.  Your Cygwin installation shouldn't change
(unless you've unselected any of the default packages) aside from the one setting.
I converted my file with dos2unix and then made a patch. Unix is the default
text type so I don't know what the problem is.
Attachment #177552 - Attachment is obsolete: true
Attachment #177552 - Flags: review?(steffen.wilberg)
Attached patch final (obsolete) — Splinter Review
Attachment #177622 - Attachment is obsolete: true
review this and if it's good please checkin
Attachment #177623 - Attachment is obsolete: true
Attachment #177651 - Flags: review?(jwalden+fxhelp)
Comment on attachment 177651 [details] [diff] [review]
fixed error in final,

>-
>+  
>+  <p>To open an URL in the Location Bar in a new tab, enter the URL in the Location Bar and press &altKey;+&enterKey;.</p>
>+  
>   <h3 id="closing_tabs">Closing Tabs</h3>

This is pretty much good enough. However, a few things:

1) The top line doesn't need the extra spaces added to it.
2) s/open an URL/open a URL/
3) Is it just me, or is the second "in the Location Bar" redundant?
4) As an FYI for the future, we try to wrap lines in help docs at 80
characters, and while current docs don't always follow this, new patches always
should.

These issues are trivial enough that it's easier for me to fix them before
checkin than for you to spin a new patch, but I want some feedback on #3 before
I check in the patch and close the bug.
(In reply to comment #11)
> (From update of attachment 177651 [details] [diff] [review] [edit])
> >-
> >+  
> >+  <p>To open an URL in the Location Bar in a new tab, enter the URL in the
Location Bar and press &altKey;+&enterKey;.</p>
> >+  
> >   <h3 id="closing_tabs">Closing Tabs</h3>
> 
> This is pretty much good enough. However, a few things:
> 
> 1) The top line doesn't need the extra spaces added to it.
> 2) s/open an URL/open a URL/
> 3) Is it just me, or is the second "in the Location Bar" redundant?
you are correct. The second "in the Location Bar" is redundant. My bad
> 4) As an FYI for the future, we try to wrap lines in help docs at 80
> characters, and while current docs don't always follow this, new patches always
> should.
> 
> These issues are trivial enough that it's easier for me to fix them before
> checkin than for you to spin a new patch, but I want some feedback on #3 before
> I check in the patch and close the bug.
> 

Comment on attachment 177651 [details] [diff] [review]
fixed error in final,

After feedback, marking r+...
Attachment #177651 - Flags: review?(jwalden+fxhelp) → review+
...and FIXED.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: