Remember last selected message should work across sessions (after restart)

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: g.teunis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The previous selected message (before restart) is not selected and displayed in
the message pane on thunderbird startup.

Reproducible: Always
Steps to Reproduce:
1. Start thunderbird, select a message
2. Watch the preview in the message pane
3. Close thunderbird
4. Open thunderbird
Actual Results:  
No message is selected and thus not shown in the message pane.

Expected Results:  
Show in message pane and select the last selected message (before restart)

(Can't imagine this isn't asked before if it is: sorry)

Comment 1

14 years ago
xref bug 276906
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
Summary: Remember last selected message doesn't show in messagepane on start → Remember last selected message should work across sessions (after restart)
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

14 years ago
This bug isn't fixed yet.
Currently my thunderbird opens with an empty preview pane (completely white) and
no message is selected.
It would be nice to see it open the last selected message.
(Reporter)

Comment 4

14 years ago
This bug isn't fixed yet, but didn't get much attention either.
Currently Thunderbird doens't open any message on start, showing a white preview
window. It would really be nice it would open the last selected message from the
previous session. (like many other mailclients seem to do).
Adding a _xref bug 268879_ to 276906.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 5

12 years ago
*** Bug 342620 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
I hoped this was fixed in 2.0b2, but it still isn't? Although I'm no programmer, I really hope this will be fixed soon. In the menu there's an option to 'remember the last selected message'. That does not work! So, please remove the option or fix it...

Comment 7

12 years ago
I agree with you Jeroen!
The bug/enhacement isn't resolved yet (i got TB 1.5.0.9) ... 
Didn't receive any mail or info if the bug will be resolved at all :(

Regards,
Sero

Updated

12 years ago
Duplicate of this bug: 370723
QA Contact: front-end

Updated

11 years ago
Blocks: 408338
Assignee: mscott → nobody
This has been working for a while now, at least to some approximation.  (Namely, the last selected message does not particularly work work for virtual folders, but that is not a session store limitation so much as a xfvf db view limitation or something like that.)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 10

9 years ago
This does NOT work in Thunderbird 3.1.1  Last selected message is once again forgotten just as this bug describes.
(In reply to comment #10)
> This does NOT work in Thunderbird 3.1.1  Last selected message is once again
> forgotten just as this bug describes.

Please file a new bug with exact steps to repeat and roughly which version(s) it was working in.
You need to log in before you can comment on or make changes to this bug.