Pasting a long string into a text field

RESOLVED DUPLICATE of bug 271055

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 271055
14 years ago
10 years ago

People

(Reporter: Michael, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: 

When I paste a long string into a text field (Longer than a text field's 
width...this box I'm typing in now is an example of one) instead of making the 
text wrap to the next line, it creates a horizontal scroll bar and keeps the 
string of text on one line.



Reproducible: Always
Steps to Reproduce:
1.Cut a string of long text from a document or txt file(must be longer than the 
width of text field from step 2)
2.Paste that string into a text field
3.Horizontal scroll bar appears, text does not wrap to next line. 

Actual Results:  
Text appeared in text field on one line, creating a horizontal scroll bar for 
the text field.

Expected Results:  
text should stay contained in the width of the text field and wrap to the next 
line.

Thanks for the great browser, I love the tabs feature and it's a big 
improvement over IE! Although trying to update a website through my site's 
admin page, is difficult when I cut and paste text into a text field.

Comment 1

14 years ago
For me, Firefox soft-wraps but does not hard-wrap text in textareas.  So I paste
a long string that doesn't contain spaces, I get a horizontal scrollbar instead
of wrapping.  Do you see the same behavior?

Comment 2

13 years ago
It happens on Linux too. And yes, it does "soft-wrapping" but no
"hard-wrapping". I hope this issue will be adressed.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 271055 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.