Long word with no spaces does not wrap in <textarea> (should use hard/emergency wrap like IE)

RESOLVED DUPLICATE of bug 92851

Status

()

RESOLVED DUPLICATE of bug 92851
14 years ago
11 years ago

People

(Reporter: blulegend, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Long text with no spaces does not wrap in textboxes.  Causes the textbox to show
horizontal scroll bars and makes posting or writing email or whatever much more
difficult.

Reproducible: Always
Steps to Reproduce:
1. type a bunch of characted in a textbox with no spaces
2. no wrapping

1. paste or type a long link into a textbox that has no spaces
2. no wrapping
Actual Results:  
Should wrap.

Expected Results:  
The tooltip should not load at all since the element is no longer there.
(Reporter)

Comment 1

14 years ago
> Expected Results:  
> The tooltip should not load at all since the element is no longer there.

Oops, that is not supposed to be there.

Comment 2

14 years ago
Clarification: this bug is about text area.

overflow: scroll;
overflow: auto;

Might be required for this, but since these do not fix this then perhaps the
real bug might be that overflow is not applying to a text area.

It also does not work with wrap="hard", but that's poor form anyhow.  overflow
should be working, however.

Comment 3

14 years ago
So what's the bug? Text only wraps if it has spaces in it. Sounds more like a
feature request to me.

overflow property (basically) affects scrollbars visibility, not wrapping.

Updated

13 years ago
Summary: Long text with no spaces does not wrap in textboxes → Long text with no spaces does not wrap in textboxes (want hard/emergency wrap in textarea, like in IE)

Comment 4

13 years ago
See http://pix.nofrag.com/28/7a/50285514a433437d741550b3442b.png to illustrate;

Mozilla/5.0 (Windows NT 5.0; rv:1.8b4) Gecko/20050909 Firefox/1.4
W2K/SP4

Updated

13 years ago
Assignee: firefox → mozeditor
Status: UNCONFIRMED → NEW
Component: General → Editor
Ever confirmed: true
Product: Firefox → Core
QA Contact: general
Summary: Long text with no spaces does not wrap in textboxes (want hard/emergency wrap in textarea, like in IE) → Long word with no spaces does not wrap in <textarea> (should use hard/emergency wrap like IE)
Version: unspecified → Trunk

Comment 5

13 years ago
*** Bug 268917 has been marked as a duplicate of this bug. ***
Related to / duplicate of bug 92851?
QA Contact: editor
Assignee: mozeditor → nobody

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 92851
You need to log in before you can comment on or make changes to this bug.