default-first-title in wizard.properties uses a variable, where it shouldn't

RESOLVED FIXED in mozilla1.8final

Status

Toolkit Graveyard
Plugin Finder Service
RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: atopal, Assigned: Doron Rosenberg (IBM))

Tracking

({l12y})

unspecified
mozilla1.8final

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
The Title of the Plugin-Finder says: Welcome to the Plugin Finder Service
The problem is, that the first part (Welcome to the) is not only used by the
Plugin Finder Service. But in german the first part depends on whether the word
in the  second part (%s) is neutrum, female, or masculine. Please follow the
guidelines in:
http://www.mozilla.org/docs/refList/i18n/l12yExamples.html#clever_strings
(Assignee)

Comment 2

14 years ago
I am doing it the same what that Firefix's update wizard does.

Since I don't see any code explaining what I need to do, please provide a patch
or a link to "correct" code.
(Assignee)

Comment 3

14 years ago
Can you explain exactly what is wrong? If not, I will mark this invalid.

Comment 4

14 years ago
doron: imagine the following:

He welcomes you to his fair
She welcomes you to her house

you've provided a fixed string "welcomes you" and a wild string <to his fair/to
her house>

the german localizers are forced to pick either "He welcomes you" or "She
welcomes you" (or "It welcomes you"), but in at least half the cases, this is wrong.

The bug is real.
(Assignee)

Comment 5

14 years ago
I know what the issue is but why is it assigned to me? Sounds like a xul:wizard
problem to me

Comment 6

14 years ago
The problem is that the wizard binding wants to generate a friendly caption if
the page author has only provided a title. On the mac, the caption is just
"Introduction", but the other platforms like to say "Welcome to the Create
Profile Wizard" (or whatever the window title happens to be). We obviously can't
fix this in the wizard binding because it doesn't know enought about the wizard.
Each wizard author has to remember to supply an optional caption for each page,
it may be left blank in any given locale if the default caption suffices.
(Reporter)

Comment 7

14 years ago
The best solution would be, to use one label for each of the titles, it would
cost us only a few bytes and it's also the way to i18n, which we should follow here.

So to clear this problem in particular, please change:

default-first-title=Welcome to the %S
to
default-first-title=Welcome to the Plugin Finder Service

and create a new lable, if you need something along the lines of "Welcome to the
Live Bookmark finder service" or whatever.
(Assignee)

Comment 8

14 years ago
Neil's reply was what I was missing from this discussion, thanks.

Sounds like something xul:wizard shouldn't be doing :)

taking and targetting 1.1.

Blocks: 272704
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox1.1

Comment 9

14 years ago
(In reply to comment #7)
>So to clear this problem in particular, please change:
> 
>default-first-title=Welcome to the %S
>to
>default-first-title=Welcome to the Plugin Finder Service
No, we do not want to change the fallback title!
We just want to allow localizers to override the fallback title.
This has to be done by the author of the instance of the wizard.

Comment 10

13 years ago
(In reply to comment #9)
> No, we do not want to change the fallback title!
> We just want to allow localizers to override the fallback title.
> This has to be done by the author of the instance of the wizard.

Neil, reading the l12y page referenced above, providing a default title just 
because en-US app coders are too lazy to remember that the first page should be
"Welcome to foo" is just plain wrong.
This is not a feature, it's a bug.

See bug 278834, too.

Comment 11

13 years ago
(In reply to comment #10)
>This is not a feature, it's a bug.
Has anyone actually filed a request for the removal of the default greeting?
(Assignee)

Comment 12

13 years ago
Created attachment 173661 [details] [diff] [review]
patch - add a label to the first page
(Assignee)

Updated

13 years ago
Attachment #173661 - Flags: review?(mconners)
(Assignee)

Updated

13 years ago
Attachment #173661 - Flags: review?(mconners) → review?(mconnor)
(Reporter)

Comment 13

13 years ago
I'm a translator and don't know too much about mozilla-development, so
nevermind, if it sounds foolish, but why don't you just write:

<!ENTITY pluginWizard.firstPage.title "Welcome to the Plugin Finder Service">

instead of:

<!ENTITY pluginWizard.title "Plugin Finder Service">
<!ENTITY pluginWizard.firstPage.title "Welcome to the &pluginWizard.title;">

The latter one is almost impossible to translate properly as I already wrote. We
use automated tools for the translation process, so that we normally don't see
one string below the other.
Comment on attachment 173661 [details] [diff] [review]
patch - add a label to the first page

Localizers don't have to follow this lead if they don't want to.   Its not
required to use pluginWizard.title in the firstPage.title string, its just
convenient and ensures that changes to the default title will get picked up
automatically, instead of duplicating the string.
Attachment #173661 - Flags: review?(mconnor) → review+
(Assignee)

Comment 15

13 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.