list of languages should allow user-supplied language codes

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
14 years ago
7 years ago

People

(Reporter: ramon.casha, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The list of languages (ie, Preferences; General; Languages) is incomplete, yet
there seems to be no way to manually enter an unlisted language code (in my
case, mt=Maltese). 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Sorry, I removed that feature to simplify the dialog. It also allowed me to
remove a ton of code. If the list is incomplete, it needs to be fixed. See bug
181541 comment 77.

Please file a bug in product Core, component Internationalization.
mt is currently disabled here:
http://lxr.mozilla.org/seamonkey/source/intl/locale/﷒0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → WONTFIX
*** Bug 310025 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

13 years ago
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=310025. This is a
critical flaw in Firefox.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 4

13 years ago
This is still WONTFIX. If anything's missing from the list, we need to fix the
list. So I've morphed bug 310028 into "enable Maltese".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WONTFIX
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
*** Bug 354196 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
A *lot* of things are missing from the list, not just Maltese. In particular, the script-subtagged versions of Chinese, Serbian, Uzbek, and Azerbaijani, plus a wide array of other potential tags. Removal of the user-input feature prevents users from using registered subtags to create language tags. Since the nature of language tags has changed somewhat, it might make some sense to revisit this bug and look at making this work for more folks.

In particular, see:
   http://www.ietf.org/rfc/rfc4646.txt
   http://www.w3.org/International/articles/language-tags/Overview.en.php
   http://www.w3.org/International/questions/qa-lang-2or3

Also, check out IE7's list of languages for comparison.
You need to log in before you can comment on or make changes to this bug.