Closed Bug 269875 Opened 16 years ago Closed 15 years ago

Make an option like Show Picture on rightclick, to show the images on pages that have downloaded only partial.

Categories

(Firefox :: General, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 218142

People

(Reporter: macster_smart, Assigned: bugzilla)

References

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Firefox 1 Final

Make an option like Show Picture on rightclick, to show the images on pages 
that have downloaded only partial.
To show that picture on page displayed not on a diferent tab or instead of the 
curent page.


Reproducible: Always
Steps to Reproduce:
1. Open one page with pictures on it
2. Let the page download partialy then click stop
3. On the images that have been not downloaded at all or partialy you can't 
make a ShowPicture on a single image to download and display that picture on 
that partialy donwloaded page

Actual Results:  
I can't view an partially downloaded picture

Expected Results:  
Make an option like Show Picture on rightclick, to show the images on pages 
that have downloaded only partial.

In the IE browser I can do this simple task but in Firefox not.
reporter, I suspect the showimage extension <http://showimage.mozdev.org/> does
what you want. I don't think this would make sense as a standard feature in the
browser, except perhaps when images are disabled in Options.
Severity: normal → enhancement
OS: Windows XP → All
*** Bug 302719 has been marked as a duplicate of this bug. ***
Refinement, plus secondary bug with pictures in href

On any page with images, if images haven't loaded, bringing up a context menu on
an image has no options for loading the image in place. Also Images in a href do
not have "View picture" option when they aren't loaded. "View picture" does show
up in a href picture that is partially loaded.

"View Picture" might be thought to provide the show in place functionality, but
instead displays the picture on its own. Returning back from viewing a picture
on its own does not show the picture in the page.

Also shouldn't the status be changed from UNCONFIRMED?

Reproducible: Always

Steps to Reproduce:
1. Go to a page with pictures on it
2. Hit stop before a picture loads
3. Right click, no way to load picture in page.

1. Go to Tools|options Click on content, Uncheck Load pictures
2. Go to a page with pictures where the pictures are not in cache
3. Right click, no option.

Actual Results:  
No option to load pictures on the page.

Expected Results:  
A menu item in the context menu upon click should show picture in place. IE
provides this functionality by a context menu item called "Show Picture" which
will cause confusion on migration.


*** This bug has been marked as a duplicate of 218142 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.