Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 270042 - Crash on startup [@ nsXULDocument::OnStreamComplete(nsIStreamLoader*, nsISupports*, unsigned int, unsigned int, unsigned char const*)]
: Crash on startup [@ nsXULDocument::OnStreamComplete(nsIStreamLoader*, nsISupp...
: crash, topcrash
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- critical with 3 votes (vote)
: mozilla1.9.3a1
Assigned To: timeless
: Neil Deakin
: 280157 306910 473174 475025 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2004-11-15 13:05 PST by Jay Patel [:jay]
Modified: 2011-06-13 10:01 PDT (History)
38 users (show)
asa: blocking‑aviary1.5-
benjamin: blocking1.9.2-
roc: wanted1.9.2-
dbaron: blocking1.9.1-
dbaron: wanted1.9.1+
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

wallpaper (852 bytes, patch)
2009-08-06 06:39 PDT, timeless
neil: review+
dveditz: approval1.9.2.2+
dveditz: approval1.9.1.8+
Details | Diff | Splinter Review

Description Jay Patel [:jay] 2004-11-15 13:05:59 PST
This is a startup crash with Thunderbird 0.9.  Here is the latest from Talkback:

Count   Offset    Real Signature
[ 144   nsXULDocument::OnStreamComplete e20cd02c - nsXULDocument::OnStreamComplete ]
     Crash date range: 05-NOV-04 to 15-NOV-04
     Min/Max Seconds since last crash: 0 - 132118
     Min/Max Runtime: 0 - 134524
     Count   Platform List 
     126   Windows XP [Windows NT 5.1 build 2600] 
     18   Windows 2K [Windows NT 5.0 build 2195] 
     Count   Build Id List 
     144   2004110312
     No of Unique Users       128
 Stack trace(Frame) 

 line 3186] 
 line 144] 
 line 672]  
     (1949077)	Comments: just wanted to launch it : I upgraded from 8 to 9.
Thnderbird launch and when loaded the bottom third of the screen is loaded with
a kind of debug information writen in red
     (1943080)	Comments: I was lauching Thunderbird when a dialog box appears.  
     (1940138)	Comments: Ich habe Thunderbird neu installiert - aber kein Start
     (1939789)	Comments: Thunderbird would not start  instead a white window wih
red written indication is shown
     (1939240)	Comments: starting the newest (german) version...
     (1926971)	Comments: heu  nothing ! 
     (1922846)	Comments: I had the  thunderbird engl. version installed. when I
downloaded the german version and had it installed  it does not  work anymore.  
     (1921835)	URL:
     (1921835)	Comments: Trying to open mail from firefox
     (1920526)	Comments: only opening the mail application
     (1919967)	Comments: after installation of update 0.9  the program starts
just 1 time  after i have the following display:                               
  -------------------------------^  <menuitem id="menu_close"
label="&closeCmd.label;" key="key_close"
     (1919967)	Comments:  accesskey="&closeCmd.accesskey;"
command="cmd_close"/>  -----------------------------------^       
<mail-urlfield    keywordrelated="true" id="expandedcontent-baseBox"
label="&originalWebsite.label;" collapsed="true"/> 
     (1919967)	Comments: 
 <key id="key_groupBySort" key="&groupBySortCmd.key;"
oncommand="MsgGroupBySort();"/>  ---------------------------------^
     (1912991)	Comments: aggiornamento 0.73 - 0.9
     (1906863)	Comments: no mails are shown anymore. After the update to 0.9. 
Istallationfile:  Installed the   
Theres 2 lines of code shown below.  The pointer in the first line is at:
label="&closeCmd.label;"  the second at:
     (1906863)	Comments:  key="&groupBySortCmd.key;"  
     (1904788)	Comments: starting the application
     (1902049)	Comments: was just starting it
     (1900777)	Comments: just started thunderbird
     (1892921)	Comments: I was just running 'azureus' and trying to open thunderbird
     (1885121)	Comments: Pressed "Check eMail" via Keyboard
     (1882973)	Comments: starting Thunderbird
     (1881908)	Comments: When opening Thunderbird .; Impossible to use !
     (1872778)	Comments: I installed thunderbird 0.9 over 0.8;  if i start via
the prompt of installation procedure  everything works; afterwards the attempt
to start again via desktop entry fails; reboot on other system had worked  on
this did not
     (1850790)	Comments: Starting thunderbird
     (1848734)	Comments: Launch Thunderbird 0.9
     (1845977)	Comments: The failure occured where I start Thunderbird
     (1842093)	Comments: Updated to 0.9 from (I think) 0.8 (it was not
deinstalled).  Before reboot Thunderbird worked just fine.  After reboot: no
menubar  no toolbar  crazy chars at bottom  then this.  
     (1833094)	Comments: i'm trying to open FireBird
     (1824880)	Comments: i startet it
     (1805350)	Comments: I've done the update  it had work one time with it and
now I can't launch Thunderbird and get my mail Please help me if you can thanks
     (1802657)	Comments: i just opend FB -  there were no statusbar or menue.  
and at the bottom there were a failure-msg something like "key... label..."..
     (1797162)	Comments: I just wanted to start the programm  but then an
error-message was shown and Mozilla Thunderbird stopped.
     (1782662)	Comments: I closed Thunderbird and re-opend it. No mails 
postings... was seen. All has gone to hell :-(
     (1767949)	Comments: installed new localized version  it worked. Closed
Thunderbird  opened later again - nothing working anymore (thunderbird opened
but i couldnA't do anything  my mails couldnA't be seen...). Restarted Computer
but no change

Another crash with a similar stack signature and trace was fixed a while back,
so perhaps it can provide some clues to what's going on here.  See bug 204935. 
Please update the component if necessary.
Comment 1 David :Bienvenu 2004-11-15 13:07:57 PST
Could this have to do with an incompatible extension?
Comment 2 Jay Patel [:jay] 2004-11-15 13:17:51 PST
Considering that most user comments mention upgrading from a previous version,
incompatible extensions might be the cause.  I'll keep an eye on the Talkback
data to see if any mention of extensions show up.
Comment 3 Scott MacGregor 2004-11-15 14:05:26 PST
i suspect there's nothing we can do here for this subset of users.

this is usually the result of folks that were using version of thunderbird
before we had an extension manager system that disabled extensions when
upgrading. So they have extensions from 0.4, 0.5 that aren't versioned at all
that are still getting loaded and bad things happen. 

Comment 4 timeless 2004-11-15 14:09:15 PST
jay: can you contact them? XUL.mfasl might be of interest.
Comment 5 Jay Patel [:jay] 2004-11-15 16:02:01 PST
Hmm... just looking at the email addresses of these users, it looks like they're
all from outside the US.  I see .de, .ch and .fr addresses.  Any locale specific
issues that might be causing this crash?

For those that have access to the internal Talkback query tool (Scott), try this:

I'll try contacting a few of them to see if they're willing to post more info in
this bug.
Comment 6 timeless 2004-11-15 16:05:18 PST
could be a bad locale, i suppose. i'd really want to see stuff before i tried to
make a guess.
Comment 7 Jerzy Konarski 2004-11-16 00:23:41 PST
I used 0.8 version in EN and I instaled the 0.9 version in FR. after instalation
thunderbird dosen't work (crash, bad inerface, ...).
Since I instaled the 0.9 version in EN and this version work good.
Comment 8 Adrien Bruneteau 2004-11-16 14:35:31 PST
 I apologize for my english language (I'm french and if somebody in the teams
speaks fluently french, that might help...)

 I was using the zip file installation of thunderbird since the 0.3 and this
time (for the late 0.9) I had taken the windows intaller the first launch was ok
but the second time it crashed showing me a strange view of the application

 I was using extensions
 - Easy get mail button O.2 (I think it already didn't work with the 0.8)
 - Minimize to tray

 I might help you better if you tell me what you're looking for...
Comment 9 Jay Patel [:jay] 2004-11-23 16:20:07 PST
I'm guessing this crash has something to do with users installing some localized
version of Thunderbird over an old en-US build in the same location.  Is there
anything we can do to prevent things from breaking or at least avoid the crash?
 It does seem like a bad idea to do a pave over install from en-US to something
else, but a lot of users are doing it anyway... 
Comment 10 Jay Patel [:jay] 2005-01-25 16:21:11 PST
This seems to be a topcrasher for Firefox (mostly MacOSX) and Mozilla builds as
well.  All comments mention updating to a recent build (with a few extensions
installed).  This seems to be a general problem with installing over an older
build with extensions that may or may not be outdated.  Updating component to
cover all products.

His a recent set of crashes for the MozillaTrunk:
Count   Offset    Real Signature
[ 3   nsXULDocument::OnStreamComplete e20cd02c - nsXULDocument::OnStreamComplete ]
     Crash date range: 19-JAN-05 to 24-JAN-05
     Min/Max Seconds since last crash: 2 - 3714
     Min/Max Runtime: 2 - 3714
     Count   Platform List 
     3   Windows XP [Windows NT 5.1 build 2600] 
     Count   Build Id List 
     1   2005012405
     1   2005012305
     1   2005011906
     No of Unique Users         3
 Stack trace(Frame) 

 line 3139] 
 line 137] 
 line 690]  

And a link to all nsXULDocument::OnStreamComplete crashes across products and
Comment 11 Jay Patel [:jay] 2005-01-25 16:22:30 PST
Scott:  We should probably pick a more detailed component and find a new owner
for this bug.
Comment 12 Benjamin Smedberg [:bsmedberg] 2005-01-26 05:27:50 PST
Jay, does this crash still appear? I suspect that bug 278534 would at least get
rid of the bad locale registration issues, although we should probably fix the
core underlying problem here as well.
Comment 13 Jay Patel [:jay] 2005-01-26 17:25:20 PST
Benjamin:  Yes, this crash is happening with Trunk builds as recent as
yesterday's.  Let me know when your patch in bug 278534 is approved and checked
in.  I can keep an eye on Talkback data after that to see if it helps crash
numbers go down.
Comment 14 Boris Zbarsky [:bz] (still a bit busy) 2005-01-26 23:18:21 PST
So looking at the talkback stack, the only thing I can assume is that it's off
by 2 lines and the script proto is null or bogus.

Jay, is there anything you can do as far as getting me locals here?
Comment 15 Jay Patel [:jay] 2005-01-27 12:44:45 PST
Boris:  Talkback is often off by 2 lines, so you're probably right about that. 
I also took a look at detailed reports from Talkback on our internal server and
something is broken...I didn't see any stacks at all and therefore couldn't find
any local var info or param lists (which normally is missing anyway).  Sorry. 
I'll look into the detailed report problem though. 
Comment 16 Gérard Talbot 2005-01-27 22:06:38 PST
Is bug 280157 a duplicate of this bug? Just asking.
Comment 17 OstGote! 2005-01-28 00:45:43 PST
*** Bug 280157 has been marked as a duplicate of this bug. ***
Comment 18 Jay Patel [:jay] 2005-03-07 18:01:27 PST
This continues to be a topcrasher and after looking into the detailed Talkback
reports problem, I have not figured out a way to get the local var info. 
Hopefully someone will be able to figure out what is going on here with the data
that we do have:

I have not been able to reproduce this, but if someone else can and knows what
specific info from users will be valuable, I can setup our feedback system to
contact them and ask for more help.

Marking topcrash+ and nominating for Aviary 1.1 to get some traction. 
Reassigning to default owners since this isn't really just a Thunderbird crash.
Comment 19 timeless 2005-03-11 04:04:55 PST
nobody isn't much of an improvement over mscott ...
Comment 20 François Gagné 2005-04-04 16:08:28 PDT
still crashing in Mozilla 1.6b1 on WinXP sp1, here the talkback ID:4840306 and
Comment 21 Henrik Gemal 2006-01-02 23:45:11 PST
today my thunderbird (nightly build 2006010205) crashes every time I try to start it.

The funny thing is that if I start it with "-profilemanager" no profiles show up in the list.
Comment 22 Wayne Mery (:wsmwk, NI for questions) 2007-02-21 11:02:24 PST
Still frequent talkback - the interesting FF ones below (no thunderbird stacks are interesting) 

TB26804437 FF2 linux 
TB28442911 FF2 win restarting after installing skype beta extension... 

TB28648803 trunk mac
Stack Signature	nsXULDocument::InsertElement() 5c9642ec
Product ID	FirefoxTrunk
Build ID	2006120408
Trigger Time	2007-01-23 19:16:24.0
Platform	MacOSX
Operating System	Darwin 8.8.0
Module	firefox-bin + (001abc00)
URL visited	
User Comments	
Since Last Crash	345 sec
Total Uptime	345 sec
Trigger Reason	SIGBUS: Bus Error: (signal 10)
Source File, Line No.	/builds/tinderbox/Fx-Mozilla1.9-Release/Darwin_8.7.2_Depend/build/universal/ppc/db/sqlite3/src//builds/tinderbox/Fx-Mozilla1.9-Release/Darwin_8.7.2_Depend/mozilla/db/sqlite3/src/pragma.c, line 846
Stack Trace 	
nsXULDocument::InsertElement()  [mozilla/db/sqlite3/src/pragma.c, line 846]
nsXULDocument::InsertElement()  [mozilla/db/sqlite3/src/pragma.c, line 4289]
nsXULDocument::OverlayForwardReference::Resolve()  [mozilla/db/sqlite3/src/pragma.c, line 846]
nsXULDocument::ResolveForwardReferences()  [mozilla/db/sqlite3/src/pragma.c, line 1064]
nsXULDocument::ResumeWalk()  [mozilla/db/sqlite3/src/pragma.c, line 3069]
nsXULDocument::OnStreamComplete()  [mozilla/db/sqlite3/src/pragma.c, line 3460]
nsStreamLoader::OnStopRequest()  [mozilla/netwerk/base/src/nsStreamLoader.cpp, line 713]
nsJARChannel::OnStopRequest()  [mozilla/modules/libjar/nsJARChannel.cpp, line 713]
nsInputStreamPump::OnStateStop()  [mozilla/db/sqlite3/src/pragma.c, line 713]
nsInputStreamPump::OnInputStreamReady()  [mozilla/db/sqlite3/src/pragma.c, line 396]
nsThread::ProcessNextEvent()  [mozilla/xpcom/threads/nsThread.cpp, line 483]
NS_ProcessPendingEvents_P()   nsBaseAppShell::Run()  [mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp, line 156]
-[AppShellDelegate runAppShell]() [/builds/tinderbox/Fx-Mozilla1.9-Release/Darwin_8.7.2_Depend/build/universal/ppc/db/sqlite3/src//builds/tinderbox/Fx-Mozilla1.9-Release/Darwin_8.7.2_Depend/mozilla/db/sqlite3/src/pragma.c, line 419]
-   nsAppShell::ProcessNextNativeEvent()  [mozilla/db/sqlite3/src/pragma.c, line 273]
nsBaseAppShell::DoProcessNextNativeEvent()  [mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp,]
nsBaseAppShell::OnProcessNextEvent()  [mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp, line 2]
nsThread::ProcessNextEvent()  [mozilla/xpcom/threads/nsThread.cpp, line 496]
NS_ProcessPendingEvents_P()   nsBaseAppShell::NativeEventCallback()  [mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp, line ]
nsAppShell::ProcessGeckoEvents()  [mozilla/db/sqlite3/src/pragma.c, line 198]
-[AppShellDelegate handlePortMessage:]() [/builds/tinderbox/Fx-Mozilla1.9-Release/Darwin_8.7.2_Depend/build/universal/ppc/db/sqlite3/src//builds/tinderbox/Fx-Mozilla1.9-Release/Darwin_8.7.2_Depend/mozilla/db/sqlite3/src/pragma.c, line 409]
-   -   nsAppShell::Run()  [mozilla/db/sqlite3/src/pragma.c, line 316]
nsAppStartup::Run()  [mozilla/db/sqlite3/src/pragma.c, line 172]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 2515]
_start()   0x8fe01048
Comment 23 Henrik Skupin (:whimboo) 2008-02-24 06:22:42 PST
*** Bug 306910 has been marked as a duplicate of this bug. ***
Comment 25 Wayne Mery (:wsmwk, NI for questions) 2008-12-15 05:24:37 PST
seems to be gone. not reports for:

- Thunderbird trunk (last 2 weeks) and TB2.0.18, 0 crashes on talkback
- FF last 8 days .... 3.0.1-4, 3.0b1-5, last 12 days 3.1b2 and pre
Comment 26 Tobias (:Tobbi) Markus 2008-12-26 04:36:36 PST
I don't think, it's gone. This issue occured to me out of sudden after upgrading from Fx 3.0.4 to Fx 3.0.5. Crash Report:
Comment 27 Henrik Skupin (:whimboo) 2008-12-26 04:55:32 PST
That's true. It's back in the topcrasher list as #9 for Firefox 3.0.5. There are about 1550 reported crashes mainly on Windows but also OS X. Even for Firefox 3.1 beta 2 it's listed as #45 with 140 crashes but only on Windows.

Tobias, could you install the 3.0.4 version and try to upgrade again? It would be interesting to see, if it's reproducible.
Comment 28 Tobias (:Tobbi) Markus 2008-12-26 05:14:41 PST
> Tobias, could you install the 3.0.4 version and try to upgrade again? It would
> be interesting to see, if it's reproducible.

This issue did only occur on my father's PC (Win XP). I'm now back home and I won't have access to it this year, anymore. Maybe someone else can help?
Comment 29 Henrik Skupin (:whimboo) 2008-12-26 05:25:07 PST
(In reply to comment #28) 
> This issue did only occur on my father's PC (Win XP). I'm now back home and I
> won't have access to it this year, anymore. Maybe someone else can help?

I've no idea if this is profile related. You could ask your father to let him send his profile to you? So you could check it out? That would be really helpful.
Comment 30 Tobias (:Tobbi) Markus 2009-01-01 11:51:48 PST
(In reply to comment #29)
> I've no idea if this is profile related. You could ask your father to let him
> send his profile to you? So you could check it out? That would be really
> helpful.

Okay, I now fetched his profile folder and installed Fx. 3.0.4 in a different folder on my system, then imported the profile and updated to 3.0.5. What I have to tell is that it does NOT crash on the Win Vista computer, the update completed successfully - no crash.

If it's helpful, I could attach his profile folder to this bug. But only if it's deleted as soon as you don't need it anymore.
Comment 31 Henrik Skupin (:whimboo) 2009-01-01 12:21:59 PST
(In reply to comment #30)
> If it's helpful, I could attach his profile folder to this bug. But only if
> it's deleted as soon as you don't need it anymore.

Please don't do that! Attachments cannot be deleted anymore.

I've taken a look at the crash report again and noticed that in frame 2 we are using a nsJARChannel. Do we probably crash while accessing a jar file, e.g trying to fetch the version information of extensions? The following crash report could be a bit more helpful: bp-3bfe1499-e1ed-47f7-bd40-71c9d2081229

This is #18 of top crasher bugs for Fx3.1b2 and #9 for Fx3.0.5 now. Looks like more and more users are affected by this bug.

Tobias, which extensions are your father using?
Comment 32 Tobias (:Tobbi) Markus 2009-01-02 07:24:08 PST
(In reply to comment #31)
> Tobias, which extensions are your father using?

As far as I can tell from the profile, he's using the following extensions:
ChatZilla 0.9.84
IE Tab 1.5.20081203
MediaPlayer Connectivity 0.9.1
Yahoo! Toolbar
Fasterfox 2.0.0 (made compatible by myself increasing the em:MaxVersion value)
Adblock Plus 1.0
DownThemAll 1.0.4
Deutsches Wörterbuch 1.0.1
Comment 33 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-01-08 18:56:31 PST
So it was gone for a few days and then reappeared when we released 3.0.5? So does it happen once when certain people upgrade, perhaps?

Maybe something bad gets in the profile, then they upgrade and crash, then the profile data is fixed at least until the next upgrade?

I hate this bad old bug but I have no idea how to make progress.
Comment 34 Dave Garrett 2009-01-12 10:00:46 PST
*** Bug 473174 has been marked as a duplicate of this bug. ***
Comment 35 steffen.zschaler 2009-01-13 02:02:55 PST
I have no idea whether this is helpful, but since everybody seems to be at a bit of a loss, I'll just throw it in: 

Looking at one of the crash reports associated with my original bugreport (Bug 473174), I noticed that it says: Crash Reason	EXCEPTION_ACCESS_VIOLATION. Now, I may be misinterpreting this of course, but if it means that there was an access violation trying to access some memory location, it may be related to some other issue that has been getting on my nerves occasionally. Among other plugins, I have installed Adobe's Acrobat plugin in what I believe is a pretty recent version. (Not sure how to find out which version it is, about:plugins doesn't seem to show the version number). Sometimes, when I have a PDF open in the browser and then close the browser, I'll get a Windows message box saying that there was an access violation accessing address "0x..." (sorry, haven't got the exact address at hand) and that the memory location could not be "read". Other than that, Firefox will shut down quite normally, though.

As I said, no idea if this is related.
Comment 36 steffen.zschaler 2009-01-28 08:40:21 PST
Is any work going on at all regarding this bug? Firefox crashes for the majority of starts on my machine at the moment, regularly forcing me to restart it two to three times before I can work with it. Even so, it will randomly mess with my plugins, in particular NoScript and TabMixPlus. It looks like these plugins are executing, but their UI parts are disabled. For TabMixPlus this mainly means I cannot close tabs any longer. For NoScript, I cannot enable JavaScript for any site, which can get quite annoying. Restarting Firefox will often help, though...
Comment 37 Ted Mielczarek [:ted.mielczarek] 2009-01-28 08:47:17 PST
steffen: are you on Windows? If so, are you willing to use a debugger to help track down the cause? Nobody is working on this bug because no developer can reproduce it. If you'd like to try with a debugger, there are docs here:

If you join #developers, someone may be willing to help you through the process.
Comment 38 Henrik Skupin (:whimboo) 2009-01-29 17:47:52 PST
Steffen, further please test with all add-ons disabled or better in Safe Mode. Does it happen also in this mode? If yes, does a new profile help?
Comment 39 steffen.zschaler 2009-03-30 02:12:16 PDT
Sorry, things have been a bit busy at my side, so I haven't actually been able to respond. Yes, I am on Windows. I was willing to do the debugger thing, but as I said, I got swamped. However, strangely enough, for some time now, I have been able to start Firefox without problems. I am currently running 3.0.7 and fearing to update to 3.0.8 lest I get the same problems again.

However, having said that, all is still not well, as some 2 out of 3 times I start Firefox, it will not start correctly some of the plugins I have installed. In particular, I am having problems with NoScript (currently version and TabMixPlus (currently at version 0.3.7pre.080728). The behaviour I observe is as follows:
  - For NoScript, the NoScript icon does not appear in the lower-right corner 
    of the browser window, as it should. However, Javascript and other 
    potentially dangerous contents is still blocked. I just don't get a chance 
    to unblock it if I need to.
  - For TabMixPlus, the easiest way to spot the bug is by looking for the 
    close-tab button. I have configured TabMixPlus to place these on the tab 
    itself, so when there is only one button at the very far right of the tab
    row, I know something has gone wrong. In this case, I will not be able to
    close any newly created tabs, even using the button that is in the wrong
Restarting Firefox often resolves the problem. However, note that the two failures seem not to be coupled. It is possible to have one of the plugins working correctly but not the other one.

Sorry again for the delay in responding,

Comment 40 Henrik Skupin (:whimboo) 2009-03-30 02:20:39 PDT
Steffen, this bug is about the crash and not for any issues with both add-ons. Please talk with the add-on authors for those problems. If you have helpful information regarding the crash please report back. If it will happen again please follow my comment 38. Thanks.
Comment 41 steffen.zschaler 2009-03-30 02:31:19 PDT
Thanks for the reply. I am aware that this is a bug about the crash, but maybe wasn't sufficiently clear about my reasons for talking about the plugins here.

I mentioned the plugin issue as it seems to be co-located with this bug (see also my comment 36 above). So, I was hoping that this behaviour may give Firefox developers some more insight into this bug. It looks like a race condition to me, and as we all know these can be fiendishly difficult to debug. At least in my experience, any information about weird behaviour that seems to be co-located may be helpful in figuring out the true source of the bug.
Comment 42 Martijn Wargers [:mwargers] (not working for Mozilla) 2009-06-14 10:44:27 PDT
Perhaps bug 497875 is related to this bug?
Comment 43 Henrik Skupin (:whimboo) 2009-06-20 02:35:55 PDT
*** Bug 475025 has been marked as a duplicate of this bug. ***
Comment 44 Wayne Mery (:wsmwk, NI for questions) 2009-07-25 11:19:53 PDT
this is going to want some attention in the next couple weeks to determine if this is TB3 needs.  3.0b3 topcrash if the TB crash stats are stable in the next several days.

FF current trunk line# differs by one vs TB based 1.9.1
- FF trunk bp-e027e6c4-eb2e-4089-ac38-c98bb2090720 
- TB 3.x bp-5205ccdf-4961-4c14-8b95-64f712090722
Comment 45 timeless 2009-08-06 06:39:02 PDT
Created attachment 392930 [details] [diff] [review]
Comment 46 Wayne Mery (:wsmwk, NI for questions) 2009-08-20 16:08:53 PDT
(In reply to comment #44)
> this is going to want some attention in the next couple weeks to determine if
> this is TB3 needs.  3.0b3 topcrash if the TB crash stats are stable in the next
> several days.

not even in the top 100 for 3.0b3 or 3.0b4pre unless I misread the stats, so not a great concern for thunderbird
Comment 47 IU 2009-09-03 07:44:58 PDT
Just go this crash today launching Minefield (3 consecutive crashes):

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090903 Minefield/3.7a1pre ID:20090903045002

I wonder if my crash could have been triggered by bug 514131

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsXULDocument::OnStreamComplete 	content/xul/document/src/nsXULDocument.cpp:3523
1 	xul.dll 	nsStreamLoader::OnStopRequest 	netwerk/base/src/nsStreamLoader.cpp:108
2 	xul.dll 	nsJARChannel::OnStopRequest 	modules/libjar/nsJARChannel.cpp:880
3 	xul.dll 	xul.dll@0x98cc6f 	
4 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:401
5 	xul.dll 	nsOutputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:191
6 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
7 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
8 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:182
9 	nspr4.dll 	PR_GetEnv 	
10 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
11 	firefox.exe 	firefox.exe@0x21a7 	
12 	kernel32.dll 	BaseProcessStart
Comment 49 Bill Gianopoulos [:WG9s] 2009-09-05 11:29:14 PDT
The recent cluster of these seems to be confined to the 20090903 nightly build.  I suspect the patch for bug 510844 somehow aggravated this issue.
Comment 50 Alfred Kayser 2009-09-08 02:46:42 PDT
Note, for the 5 crashreports mentioned in #48, only one is related to nsJARInputStream, so it is doubtful that bug 510844 is the cause of this.
On 20090903 there a number of other patches committed and backed out because of tinderbox issues.
Comment 51 Phil Ringnalda (:philor) 2009-10-26 18:42:45 PDT
Comment 52 Wayne Mery (:wsmwk, NI for questions) 2010-01-04 16:26:51 PST
#98 crash for Thunderbird v3.0.0, so if reporters confirm this is fixed with trunk build and the patch isn't offensive, suggest this is wanted for 3.0.1.
Comment 53 Wayne Mery (:wsmwk, NI for questions) 2010-01-04 16:28:10 PST
Comment on attachment 392930 [details] [diff] [review]

(guess it can't make 3.0.1)
Comment 54 Daniel Veditz [:dveditz] 2010-01-08 13:51:44 PST
Comment on attachment 392930 [details] [diff] [review]

Approved for, a=dveditz for release-drivers
Comment 55 Sebastian Redl 2010-01-22 01:12:28 PST
This appears for me in Fx 3.6, but only if NoScript is enabled. When will the wallpaper be brought to the 1.9.2 branch?
Comment 56 Daniel Veditz [:dveditz] 2010-02-02 08:42:32 PST
Comment 57 Daniel Veditz [:dveditz] 2010-02-05 13:49:08 PST
Comment on attachment 392930 [details] [diff] [review]

Approved for, a=dveditz for release-drivers
Comment 59 Al Billings [:abillings] 2010-02-26 16:42:36 PST
What is the scenario to reproduce this bug pre-fix? I see that No Script is involved in once instance but no details.
Comment 60 Al Billings [:abillings] 2010-03-22 11:20:27 PDT
QA has nothing to do here to verify this fix.
Comment 61 Sebastian Redl 2010-03-25 03:32:03 PDT
I can confirm that my problem is fixed in 3.6.2.

Note You need to log in before you can comment on or make changes to this bug.