Auto-Scroll doesn't work outside the range of a page and Scroll-with-Mouse doesn't work altogether

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: alexxir, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I use Kensington 4-botton Trackball (with their latest 6.03 driver)and with 2
single bottons set to scroll Up & Down respectively & "Accord" bottons to
activate Scroll-with-Mouse function of the driver (when you simultaneously press
2 upper or lower Left+Right bottons to acivate Autoscrool). 
#1:You can't scroll the page if you are outside the range of the page, e.g. in
the heading of the page (where the BACK & FORWARD bottons are) the Scrolling
doesn't work unless you lower the cursor on the page/ or bring it up from the
Status Bar on the bottom). 
#2.The Scroll-with-Mouse doesn't work altogether! It's the reason why I never
switched to Netscape 6 or 7 after VER. 4.8. All versions of I.E. & all Netscape
versions up to 4.8 never had this problem!!! 
#3. All SOUND SCHEMES THAT WORK IN MY WINDOWS XP (or any other versions) DON'T
WORK  WITH MOZILLA FIREFOX - IT'S TOTALLY MUTE AND SO THERE'S NO AUDIO
CONFIRMATION TO ANYTHING THAT IS DONE IN THE BROWSER!!!! PLEASE ADDRESS IT AND
FIX IT!!!!!!!!

Reproducible: Always
Steps to Reproduce:
1. GET KENSINGTON TRACKBALL, SET RIGHT BOTTOM AND RIGHT TOP BOTTONS TO SCROLL
UP/DOWN RESPECTIVELY AND BOTTONS 1+2 (LOWER LEFT + LOWER RIGHT) TO INVOKE
"SCROLL-WITH-MOUSE". TEST & MAKE SURE IT WORKS WITH Netscape 4.* & Internet
Explorer as an example.
2. Try it in FireFox 1.0 & see that it doesn't work if you are outside the
screen's active range if you use regular Scroll Up/Down and Scroll-with-Mouse
doesn't work completely. Your settings in the browser such as Smooth Scrolling
and Autoscroll have ABSOLUTELY NO BEARING on the trackball's performance.
#4. When saving .JPG's (OR ANY OTHER IMAGE)from the internet to a designated
folder, unexpectedly this unrequested "DOWNLOADS" window appears (with "Clean-UP
Desktop" button. This window is totally useless!!!) Please add a function to
disable it - it's SUCH A NUISANCE, + I don't need a intermediary to monitor the
number of images I download!!!!!!!!!!! PLEASE REMOVE OR ADD A DISABLE SWITCH!!!!!!!
#5. YOUR "COPY IMAGE" FUNCTION (when surfing and want to copy an image from the
internet site by right-clicking on it and choosing "COPY IMAGE") DOESN'T WORK!!
When performing this function and trying to paste the image to e.g. a DESKTOP,
the PASTE function is GREYED-OUT!!! Int. Explorer has it and it works
flawlessly! I guess you forgot to implement this function. PLEASE FIX IT - it's
imperative to have it !!!!!!! 
Actual Results:  
NOTHING

Expected Results:  
ALLOW TO FREELY AND SMOTHLY SCROLL UP & DOWN WITHOUT ANY HESITATIONS.
I've spent numerous hours with Kensington R&D team as a beta-tester to make sure
that this function  (which I stumbled accross by accident) was implemented and
now widely advertised, just to have it completely lost in your application...
PLEASE ADDRESS IT!!

Today I installed your browser and it's pretty good in its simplicity, (I was a
beta-tester before), and the first thing noticed is the total silence...... :-(
ONCE AGAIN - ALL OF THE WINDOWS "SOUND SCHEME" sounds ARE COMPLETELY DISABLED IN
YOUR BROWSER! :-(( :-((
Well, not everyone is either deaf or is NOT interested in audio sound
confirmation to any activities that they might be performing while browsing the
internet! 
PLEASE MAKE YOUR BROWSER 100% COMPATIBLE WITH Internet Explorer's sound schemes
- it's one of the reasons why I still enjoy using I.E. & even older Netscape 4.8
Communicator.
Want to have a REAL WINNER on your hands instead of a MUTED wannabe? DO IT !!!

Updated

14 years ago
Group: security
Product: Browser → Seamonkey

Comment 1

14 years ago
moving to Firefox, basing on your build string
Component: General → General
Product: Mozilla Application Suite → Firefox

Comment 2

13 years ago
I'm not familiar with the kensington, but here are some starters for you.
1. please only file one issue per bug - read
https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html
2. for usability issues and questions suggest you visit the firefox user forums
http://forums.mozillazine.org/

For this bug we focus on one item ...

Are you saying this mouse is supposed to let you scroll when it's outside the
page area (eg in the menu area)?vs  I've never heard of that and unless there is
some fancy magic I don't think FF supports that capability. Is there a browser
that does?

Based on this one issue, this bug is probably INVALID, working as designed.
Severity: major → normal

Comment 3

13 years ago
> Are you saying this mouse is supposed to let you scroll when it's outside the
> page area (eg in the menu area)?vs  I've never heard of that and unless there is
> some fancy magic I don't think FF supports that capability. Is there a browser
> that does?

yes. Opera 6 and Opera 8 both let you scroll when in the menu area using
wheelmouse. 

this bug is an (incoherent rant) duplicate of Bug 194696
 
> Based on this one issue, this bug is probably INVALID, working as designed.

most other programs let you [mousewheelscroll the last active area when
mousecursor is over menu-areas] eg windows explorer, acdsee, filezilla, wordpad,
opera...
the only programs i have that don't, are IE5.5, gimp, firefox and thunderbird.

the few opera users that i know, cite this as a reason for not liking firefox.

Comment 4

13 years ago
Marking INVALID (too many issues cited).  Again, one issue per bug 


(In reply to comment #3)
> yes. Opera 6 and Opera 8 both let you scroll when in the menu area using
> wheelmouse. 
>> most other programs let you [mousewheelscroll the last active area when
> mousecursor is over menu-areas] eg windows explorer, acdsee, filezilla, wordpad,
> opera...

created bug 308215 to cover this function

 
> this bug is an (incoherent rant) duplicate of Bug 194696

the author of bug 194696 wants scrolling to work only over tabs.

 

(In reply to comment #0)
> I use Kensington 4-botton Trackball (with their latest 6.03 driver)and with 2
> single bottons set to scroll Up & Down respectively & "Accord" bottons to ...

see also other bugs related to mouse issues, for example bug 20618 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.