Note: There are a few cases of duplicates in user autocompletion which are being worked on.

WinWord/TextPad dead keys are not supported

RESOLVED WONTFIX

Status

()

Core
Widget: Win32
--
enhancement
RESOLVED WONTFIX
13 years ago
a year ago

People

(Reporter: Kai Bolay, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:?, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

I'm using a US-English keyboard on a US-English Windows XP machine. 

Yet, both MS-WinWord and TextPad (and probably many more applications)  support
entering accented characters and umlauts using CTRL-<:> + [aeiou] for äëïöü,
CTRL-<'> + [aeiou] for áéíóó, CTRL -<`> + [aeiou] for àèìòì, as well all,
CTRL-<&>+<s> for ß, CTRL-<,>+<c> for ç, CTRL-</>+<o> for ø, and probably a few
more.  

It would be very, very convenient to be able to use the same "dead keys" when
composing e-mail (or filling out web forms or even creating web wages) with Mozilla.

I know Windows XP allows me to select a "United States-International" IME. This
IME works with Mozilla, but the "dead keys" are <"> <'> <`> <~>, etc. (without
any CTRL). These dead keys get into the way of normal typing.

Supoorting the MS-WinWord and TextPad compatible "dead keys" would allow anyone
to enter "special" characters without having to switch keyboard drivers and
impeding normal text entry.


Reproducible: Always
Steps to Reproduce:
Using a US-English keyboard on a US-English Windows XP machine and try to enter
and umlaut or accented character using MS-WinWord/TextPad shortcuts into a
textbox or the compose window for mail. 

Actual Results:  
CTRL+<'>+<e> will produce "e", not "é". Similar results with all other shortcuts.


Expected Results:  
produce "é" and honer all other "dead keys"

Comment 1

13 years ago
could you please find a url @microsoft.com which documents this behavior? i
tried mso2k3's online help and couldn't find anything (i didn't try very hard,
but my quick searches all failed)
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)

> could you please find a url @microsoft.com which documents this behavior?

http://office.microsoft.com/assistance/hfws.aspx?AssetID=HP051865621033

Updated

13 years ago
Assignee: jag → win32
Component: XP Toolkit/Widgets → GFX: Win32
QA Contact: jrgmorrison → ian

Updated

13 years ago
Component: GFX: Win32 → Widget: Win32

Comment 3

13 years ago
*** Bug 275025 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
Can someone find if this functionality is system-wide (API to access it) or it
is application specific (which user DLL)?

Comment 5

13 years ago
No, this behaviour is MS Word specific. Ms Excel, MS Wordpad and MS Notepad do
not support this feature. The MS Character Map does not show these key
combinations as system wide shortcut keys either.
If one decides that this feature should be implemented then most likely it
should be cross platform and not limited to Win32 widget code only.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)

> No, this behaviour is MS Word specific. Ms Excel, MS Wordpad and MS Notepad do
> not support this feature.

In fact MS WordPad (Version 5.1, Build 2600_xpsp_sp2_rtm.040803-2158) DOES
support this feature. Excel, and Notepad don't.

 > The MS Character Map does not show these key
 > combinations as system wide shortcut keys either.

Unfortunately :-(

> If one decides that this feature should be implemented 

Please! ;-)

 > then most likely it should be cross platform and not limited 
 > to Win32 widget code only.

I wouldn't mind that. Thanks!

Comment 7

13 years ago
Ok, I like the idea enough to try to implement this using XBL. If someone thinks
that this won't work or XBL is totally wrong approach, please speake up now,
before I finished to read all these specs :)
(Reporter)

Comment 8

12 years ago
I've written an extension which fixes this problem for Firefox and Thunderbird. Please check out http://zombiekeys.bolay.us/zombiekeys.xpi and let me know what you think. Since this is my first Mozilla extension I'm hoping to get it reviewed widely so I can make improvements if needed.

Comment 9

10 years ago
You know, I'd swear there was another project that did this, can't seem to find it though.
Just to be confusing there are a number of different ways to trigger digraphs that any friendly project would allow a user familiar with that combination to use.

Putty uses super + tick + letter
Screen uses ^A^V + tick + letter  (most annoying due to extra ^A trigger needed by screen)
Vim uses ^K + tick + letter
All 3 have loosely same format, but the sets don't perfectly overlap (Vim's is nicest and most nicely documented IMO).
And of course, Vim offers entry of arbitrary chars by unicode hex, similar to the decimal variant listed in zombiekeys docs.

I seem to remember that that aforementioned project I had used thoughtfully did a union of various sets of digraphs and also allowed the user to choose the starting input trigger.
I'm having no luck finding it, however.
Assignee: win32 → nobody
QA Contact: ian → win32

Comment 10

a year ago
@Realraven (Axel Grude), Kai Bolay:
Any chance that you could implement this in the LibreOffice Office productivity suite:
https://bugs.documentfoundation.org/show_bug.cgi?id=71176

Thanks
Whiteboard: tpi:?

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.