If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Copying text will blank the clipboard while running Remote Desktop (RDP)

RESOLVED WORKSFORME

Status

()

Core
General
--
major
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: arbi, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When a MS Remote Desktop session exists on the client computer:
Copying text from Firefox (on the client computer) either from the body of any
site or from the address bar will blank (empty the contents of) the clipboard so
that you cannot paste what you've tried to copy to anywhere.  This happens about
85% of the time with each copy attempt.  This happens even if the Remote Desktop
window is minimized.  When Remote Desktop session is closed entirely, Firefox
returns to normal with no copying problems.

Reproducible: Always
Steps to Reproduce:
1. Run Firefox and an MS Remote Desktop session.
2. Minimize the Remote Desktop session (not mandatory)
3. Go to ANY site
4. Try to copy text either from the body of page or from the address bar.
5. Try to paste it back anywhere.
6. Repeat step #4 if first try didn't reproduce bug.  It happens most of the
time so if you do it twice it's almost 95% certainty.
Actual Results:  
Most of the time it will empty the contents of the clipboard and you cannot
paste what was intended as a result.

Expected Results:  
Should have copied the text to the clipboard.

I have confirmed and reproduced this on 2 other client computers with remote
desktop to 3 different computers.

I listed this bug as "major" because it is "a major feature is broken" for
anyone who runs Remote Desktop and Firefox is now 1.0 with mainstream public
attention.  On the other hand, the bug is "non-existant" for anyone who doesn't
run Remote Desktop.

Comment 1

13 years ago
related/same as bug 243758

Updated

13 years ago
Depends on: 243758
(Reporter)

Comment 2

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> 
> When a MS Remote Desktop session exists on the client computer:
> Copying text from Firefox (on the client computer) either from the body of any
> site or from the address bar will blank (empty the contents of) the clipboard so
> that you cannot paste what you've tried to copy to anywhere.  This happens about
> 85% of the time with each copy attempt.  This happens even if the Remote Desktop
> window is minimized.  When Remote Desktop session is closed entirely, Firefox
> returns to normal with no copying problems.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Run Firefox and an MS Remote Desktop session.
> 2. Minimize the Remote Desktop session (not mandatory)
> 3. Go to ANY site
> 4. Try to copy text either from the body of page or from the address bar.
> 5. Try to paste it back anywhere.
> 6. Repeat step #4 if first try didn't reproduce bug.  It happens most of the
> time so if you do it twice it's almost 95% certainty.
> Actual Results:  
> Most of the time it will empty the contents of the clipboard and you cannot
> paste what was intended as a result.
> 
> Expected Results:  
> Should have copied the text to the clipboard.
> 
> I have confirmed and reproduced this on 2 other client computers with remote
> desktop to 3 different computers.
> 
> I listed this bug as "major" because it is "a major feature is broken" for
> anyone who runs Remote Desktop and Firefox is now 1.0 with mainstream public
> attention.  On the other hand, the bug is "non-existant" for anyone who doesn't
> run Remote Desktop.

Been three months now.  This really needs to be fixed.

*** This bug has been marked as a duplicate of 84973 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
No longer depends on: 243758
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of 84973 ***

This is NOT a duplicate of 84973.  84973 is copying from a remote app.  This one
is copying from your LOCAL computer to itself.  A Remote Desktop session
triggers it but nothing from the remote computer is copy or pasted to reproduce
this bug.  Perhaps my original post was not clear enough.  When I said "client
computer" I mean "local computer".
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

13 years ago
Please fix this major problem, we experience it here on 5 different machines
(all users are running Remote Desktop when this issue occurs).

I can reproduce it on both released Firefox 1.0 and the latest (21 February
2005) trunk builds.

Comment 6

12 years ago
This is broken since at least a year now.

Please fix this, as right now RDC window needs 
to be closed to be able to cut/copy from FireFox 
(or you end up trying to copy/paste 20 times to 
make it copy once)

Maybe some timing issue? If RDC is open all 
cut/copy operations are supposed to change the 
clipboard on the remote computer too.

Comment 7

12 years ago
I can reproduce this bug. It is very big annoyance. Is there a purposed time
that this bug will be looked into?

Comment 8

12 years ago
I also constantly have this problem as I often have one or more Remote Desktop
sessions open. It really bothers me and I oftne have to resort to dropping the
URL on the desktop to make and shortcut and copying the URL from the properties
of the shortcut. I have been experiencing this problem for a while now -- at
least since 1.0 -- but I think it used to happen on earlier versions too.

(In reply to comment #0)

> Reproducible: Always
> Steps to Reproduce:
> 1. Run Firefox and an MS Remote Desktop session.
> 2. Minimize the Remote Desktop session (not mandatory)
> 3. Go to ANY site
> 4. Try to copy text either from the body of page or from the address bar.
> 5. Try to paste it back anywhere.
> 6. Repeat step #4 if first try didn't reproduce bug.  It happens most of the
> time so if you do it twice it's almost 95% certainty.
> Actual Results:  
> Most of the time it will empty the contents of the clipboard and you cannot
> paste what was intended as a result.

Comment 9

12 years ago
I too, along with 10 others in the office im in, can confirm this bug as well.

Im about to ditch firefox, because it impacts my work.

When cut/copy/paste between the remote desktop and the local computer (or vice
versa) is not triggered as mentioned above.

This is so damn annoying and hindering to work, im about to stop using firefox
and return to IE just so I can use the basic copy and paste functionality!

Dev Team, please, what do you need from us to try and get this fixed?

I just downloaded Firefox 1.5 Beta 1 and the problem STILL exists.

Bugzilla is here for a reason. please address this issue! What do you need to
help resolve it? Come on guys its nearly been an entire year without being
addressed or even looked at.

This is a serious problem and should be addressed, can I get some confirmation
or request for more information please from a QA member?

Those in this bug report have taken the time to submit the bug for you to
review, at least provide some information on whats being done to resolve this issue.

Cheers,
Andrew

Comment 10

12 years ago
Any update?
I am unable to reproduce this problem using a recent trunk build
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050918
Firefox/1.6a1
(Reporter)

Comment 12

12 years ago
(In reply to comment #11)
> I am unable to reproduce this problem using a recent trunk build
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050918
> Firefox/1.6a1

Problem still exists as of Firefox 1.0.7 release.

Comment 13

12 years ago
(In reply to comment #11)
> I am unable to reproduce this problem using a recent trunk build
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050918
> Firefox/1.6a1

Im having trouble using copy/paste shortcuts myself with 1.6a1 - Seems to not be
resolved in this build either.

Comment 14

12 years ago
I can confirm that this is still completely reproducible in the 1.0.7 Firefox
release and the current nightly Deer Park build. As per the bug filing
instructions I can confirm that the problem exists in the Mozilla core
application suite. I've just tried it in the Windows nightly release
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/mozilla-win32-installer.exe
 5th October 2005. 
Platform: Windows XP SP2
I have found this EXTREMELY frustrating in Firefox, 99% of the time you CANNOT
copy text from the address bar when a Remote Desktop session is running. VERY
occasionally it works, but as another poster has suggested, this appears to be
timing related rather than as a result of a reproducible set of steps.

Interestingly - there used to be a very similar bug in Eclipse which seemed to
be related to VNCViewer: https://bugs.eclipse.org/bugs/show_bug.cgi?id=66285
(just had trouble copying and pasting that URL!)

Just to re-iterate the steps to reproduce:
1. Run firefox/deer park/mozilla
2. Go to a web page e.g. http://www.mozilla.org/projects/firefox/
3. Alt+D into address bar
4. Ctrl+C to copy selected text
5. Switch to a text editor
6. Ctrl-V to paste, web address gets pasted.
7. Open a Remote Desktop session, perform same series of events (use a different
website e.g. http://www.mozillazine.org/ to ensure copied text is different), 
8. Switch to a text editor
9. Text does not get copied.

I have also just tried to copy and paste this text out of this TextArea to save
it before I post it; the clipboard is EMPTY, but I can drag and drop it. 

VERY frustrating. Please, please, please fix. 
(Reporter)

Comment 15

12 years ago
As of Firefox version 1.5 RC1, the problem still exists.  Has there been any progress whatsoever with this bug?

Comment 16

12 years ago
This bug has been a problem even since the very early versions of Firefox.  It is not just an annoyance.  It is infuriating.

Comment 17

12 years ago
I cant believe this has not even been acknowledged yet by a development team member.

I agree Rob, this bug is terrible - I shouldnt have to stop and spend (literally) 30 seconds or more to get a simple cut and paste going between RD and my local computer (usually I close the RD session in frustration).

One thing I have noticed which 'seems' to help, is if you highlight text locally (drag mouse over text), and hit CTRL+C, then on the RD end, right click>Paste.

Can anyone else confirm this seems to work better than always? Its not a fix however, this does not always work either.

Comment 18

12 years ago
This bug is still present in 1.5.0.1.
Firefox 2.0 is in the works.
Will developers acknowledge the bug and fix it before release?
(Reporter)

Comment 19

12 years ago
Bug is still present in 1.5.0.2

I am the original poster to this bug thread and it has been 1.5 years after NUMEROUS new versions.  With every new version I always get dissapointed that such a MAJOR crippling bug (for anyone using Remote Desktop) has gone unfixed.

Does anyone know if the "Assigned To:" field is going to the wrong guy?  This bug is completely and EASILY reproducible and confirmed by so many people.  How can I get a Firefox dev to just look at it?  It can probably be fixed in one line of code somewhere.  How can we get a dev to just at least ACKNOWLEDGE the bug and say "okay we reproduced it and we will fix it in a year or two"?

Comment 20

11 years ago
I totally agree with you arbi. This bug targets half of our company. Most of them already switch to Opera, because of this bug. Help us devs!!! Help us Mozzarella Foundation!!!

ehh... maybe IE7 or Opera isn't that bad alternative?

Comment 21

11 years ago
(In reply to comment #20)
> I totally agree with you arbi. This bug targets half of our company. Most of
> them already switch to Opera, because of this bug. Help us devs!!! Help us
> Mozzarella Foundation!!!
> 
> ehh... maybe IE7 or Opera isn't that bad alternative?
> 

Apparently this issue is not important.

Comment 22

11 years ago
It's still present in 1.5.0.4, and it seems is not important as most here said.
arbi - 
does this happen on current trunk (please no more comments people about v1.5)?
please set the version field in the bug if it exists on trunk.
please list new minimal testcase (i.e. eliminate all steps that are not essential) if comment 0 is not an accurate, minimal testcase.

does clipbrd.exe show that clipboard is empty as stated in summary?  
 if so, before start step 1 put text in clipboard and verify it's in clipbrd.
 at what step does the text disappear?
Component: General → General
Product: Firefox → Core
Version: unspecified → 1.8 Branch
Assignee: bross2 → nobody
QA Contact: general → general

Comment 24

11 years ago
I am also having this problem and have been for some time on WinXP and Win2k3.  Please fix this!!!  I agree that this is enough to push me to (shudder) IE7.

Comment 25

10 years ago
I'm having this problem constantly.  FF 2.0.0.6 (amazing, it didn't magically fix itself...), Windows XP SP2.  Clipbrd.exe shows "ClipBoard Viewer cannot display information in its current format."  I don't have permissions to update the bug itself.
DonGato
Arbi
-All-

please try with XP SP2 and newer version of remote desktop - Remote Desktop
Connection (Terminal Services Client 6.0), documented in microsoft KB925876.

Improved for you?

WFM, with rare exception (some of which are fixed on trunk).  see also issues of bug 315702, bug 343132, bug 206435.
(Reporter)

Comment 27

10 years ago
Well it's been 3 years.  I have gone through 2 entire PC hardware replacements and multiple OS re-installs.  While the problem lingered roughly for the first 2 years, somewhere in the last year I think the problem ceased to exist for me.

I cannot currently reproduce the problem although two people on this thread indicate it still exist, or a variation of it still exists.  Since I am the thread starter, what am I supposed to do now?  Am I supposed to change resolution to FIXED?  Please let me know what I am supposed to do to this thread/entry.
> Since I am the thread starter, what am I supposed to do now?  Am I supposed to change resolution to FIXED?  

since you are the reporter I'd close it - but make it WORKSFORME, not FIXED.   
  (see https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution )

if others still see problems they can still comment in the bug after it's closed

Comment 29

10 years ago
What good is commenting in a closed bug to those of us with the problem?  We can't even get mozilla to pay attention to open bugs.  And re-filing the bug will probably set us back several years on the waiting list...
(In reply to comment #29)
> What good is commenting in a closed bug to those of us with the problem?  

cause we'll know you still have problem?


> We can't even get mozilla to pay attention to open bugs.  And re-filing the bug
> will probably set us back several years on the waiting list...

There is no such thing as a waiting list. But in fact newer bugs tend to get more attention.  You are right in stating the bug hasn't gotten any developer attention.  That's not  unexpected given this affects so few users, and (apparently) no affected developers use remote desktop - if there were they'd be jumping up and down. In the end remember this is open source - if we who are seeing these problems can't help each other then we can't reasonable expect others to pay attention.

back to the main issue...

clearly, your problem is not the same as the reporter's - his problem is gone and thus this bug in the strictest sense is done - unless the problem is the same but you're not using "it" in the same way or haven't brought your PC to the same level of repair as the reporter.  Understandably people sign on with the same apparent problem and then we all strive to find the common issue and ultimately the same cause, but in fact often they are not all the same problem.  And having more than one problem in the same bug almost always makes things more difficult to diagnose - it's like having a meeting about 10 different problems  and everyone talking at once, nothing gets the focus it deserves.  So on the contrary in my experience, a new bug, laser focused on _your_ problem is more likely to make headway for your issue.  

So I recommend anyone who sees a problem to file a new bug and cite the new bug number here is this bug, that way others who are interested in your issue can sign on to your bug. But first, test a nightly trunk build and report whether it fixes your problem.   (the trunk install will not affect your FF2 install) http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

By the way, most of the copy / paste problems, including those with remote desktop, have been related to windows/tab creation or focus problems - so you might want to seek out those types of bugs in researching your own problem.  And some have been fixed on the trunk (which will become FF3).
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.