Unable to manage identities when signature file is not on given path

VERIFIED FIXED in mozilla1.9alpha5

Status

VERIFIED FIXED
15 years ago
11 years ago

People

(Reporter: phil.pishioneri, Assigned: whimboo)

Tracking

(Blocks: 1 bug, {verified1.8.1.5})

Trunk
mozilla1.9alpha5
PowerPC
macOS
verified1.8.1.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Thunderbird version 0.9 (20041103)

Imported entire profile from Mozilla 1.8a4.

Attempting to "Manage Identities..." on an account which has multiple identities
fails (button appears to do nothing).  Checking the javascript console, I see
that this error gets logged when I click the button:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgIdentity.signature]"  nsresult:
"0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://messenger/content/am-identity-edit.js :: saveIdentitySettings :: line
145"  data: no]

The existing identities are still usuable in Message Composition.

Reproducible: Always
Steps to Reproduce:

Updated

14 years ago
Component: Preferences → Account Manager
Reporter, could you test it again with a current nightly build? This error
should have been fixed and is not visible anymore. If it's working for you, this
bug could be closed as WFM.

Comment 2

13 years ago
I have the same problem. 

1. Open Tools -> Account Settings...
2. Push Manage Identities... on the default account and nothing happens.

Reading this bug report I could find the following Javascript error:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgIdentity.signature]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://messenger/content/am-identity-edit.js :: saveIdentitySettings :: line 199"  data: no]


Thunderbird version 1.5.0.5 (20060719)
Mac OS X 10.4.7 build 8J2135 (Intel)

Reproducible: Always


Note: Manage Identities opens without error with other accounts but not with the default account. The solution cannot be to delete the account and redo everything.

Comment 3

13 years ago
Replying to myself, the problem is related to a deleted signature file.

I had configured a signature text file and had later moved it to another place. After that Thunderbird did not give an error about the missing file nor could it open the Manage Identities dialog. It just stayed mute.
(Reporter)

Comment 4

13 years ago
I had fixed this myself by modifying my identities so that I didn't get the error.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Please don't resolve this bug as WFM while it's working for you after the update of your identity.

Does it still occur when you move your signature again? The identity dialog has to be opened although when the signature doesn't exist anymore.

@Niko: Does the path of your signature point to an existing directory?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Confirming based on the comments here and a report of an user on IRC having the same problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 303545
This WFM with Thunderbird version 2.0pre (20070309) on Mac OS X. Reporter can you please test again if it still happens for you? Please also run in Safe Mode or deactivate all extensions.
QA Contact: account-manager
I tested again and now I can reproduce this issue with version 2.0.0.4pre (20070429).

Scott, does it have the priority to be added to your meta upgrade bug?
Posted patch patch v1.0Splinter Review
Only set the signature if the given path really exists. Otherwise fall back to none. It also fixes the call of exists() in GetSigFolder.
Assignee: mscott → hskupin
Status: NEW → ASSIGNED
Attachment #263357 - Flags: review?(mscott)
Assignee: hskupin → nobody
Status: ASSIGNED → NEW
Component: Account Manager → MailNews: Backend
Product: Thunderbird → Core
QA Contact: account-manager → backend
Version: unspecified → Trunk
Status: NEW → ASSIGNED
Assignee: nobody → hskupin
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
(Reporter)

Comment 10

12 years ago
As I wrote in comment 4, I (reporter) can no longer duplicate this problem.
(In reply to comment #10)
> As I wrote in comment 4, I (reporter) can no longer duplicate this problem.

Although you reported that bug you are not the only person who is affected by this issue. It's still visible if the signature file is not on the given path. It's a bug and has to be fixed.

Updated

12 years ago
Attachment #263357 - Flags: review?(mscott) → review+
(Reporter)

Comment 12

12 years ago
(In reply to comment #11)
> (In reply to comment #10)
>
> Although you reported that bug you are not the only person who is affected by
> this issue.

Yes, but repeatably asking me to test isn't going to help any. I don't use any signatures, and don't recall how I modified my profile in comment 4.
Summary: javascript error attempting to manage identities → Unable to manage identities when signature file is not on given path
Comment on attachment 263357 [details] [diff] [review]
patch v1.0

This patch checks if a signature really exists on the given path. Otherwise you are unable to manage identities on Mac OS X.

David, I accidentally made this patch against the 1.8 branch. But there was no change of the code in saveIdentitySettings on the trunk. If you wish a patch against the trunk I could deliver one.
Attachment #263357 - Flags: superreview?(bienvenu)

Comment 14

12 years ago
Comment on attachment 263357 [details] [diff] [review]
patch v1.0

looks good, thx. I'll figure out how to land this.
Attachment #263357 - Flags: superreview?(bienvenu) → superreview+
Whiteboard: [checkin needed]
Checking in am-identity-edit.js;
/cvsroot/mozilla/mailnews/base/prefs/resources/content/am-identity-edit.js,v  <--  am-identity-edit.js
new revision: 1.12; previous revision: 1.11
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → mozilla1.9alpha5
verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a5pre) Gecko/20070511 Thunderbird/3.0a1 ID:0000000000 [cairo]
Status: RESOLVED → VERIFIED

Comment 17

12 years ago
Henrik, have you considered asking for branch approval on the patch? It's a pretty trivial fix, and it seems like enough people are hitting this that it'd be worth fixing for 2.0.0.x.
Comment on attachment 263357 [details] [diff] [review]
patch v1.0

Simple fix which gives back the possibility to edit identities when sig file is missing. Asking for approval 1.8.1.5.
Attachment #263357 - Flags: approval1.8.1.5?
Adam, where do you see that a lot of people are seeing this? I wasn't able to reproduce it under Windows and Linux. Are this OS also affected or do you have more Mac OS users?
I've been running into the bug for a while now and couldn't figure out what the problem was. I asked Adam today and he figured out that even though the signature checkbox was unchecked, it was still trying to load my old signature file and I had to re-check, clear the textbox, and un-check to open the dialog.

Adam said it was Mac OSX only earlier I think, but I'm sure quite a few people have run into this problem.

Comment 21

12 years ago
Comment on attachment 263357 [details] [diff] [review]
patch v1.0

a=mscott for 1.8.1.5
Attachment #263357 - Flags: approval1.8.1.5? → approval1.8.1.5+

Updated

12 years ago
Whiteboard: [checkin needed (1.8 branch)]
Using new keyword for checkin-needed status.
Keywords: checkin-needed
Whiteboard: [checkin needed (1.8 branch)]
Except you're supposed to keep the special instructions you cleared from the whiteboard. I for one use it to filter away the bugs to be checked into the branch.
Whiteboard: [checkin needed (1.8 branch)]
Landed on MOZILLA_1_8_BRANCH.
Keywords: checkin-needed
Whiteboard: [checkin needed (1.8 branch)]
Keywords: fixed1.8.1.5

Comment 25

12 years ago
Verified FIXED using version 2.0.0.5pre (20070710) on Mac OS X 10.4.10. Thanks again for the fix, Henrik.
Keywords: fixed1.8.1.5 → verified1.8.1.5
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.