Status

()

defect
--
major
RESOLVED DUPLICATE of bug 237582
15 years ago
14 years ago

People

(Reporter: mh406, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0 (Debian package 1.0-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0 (Debian package 1.0-2)

When attempting to load a new page, if there are any problems with DNS
resolution, Firefox hangs until the query times out or provides an answer. (I
have had problems with http://edith.freelinuxhost.com/ and the ads on
http://www.sweetcollect.co.uk but currently they are working fine because they
are not having DNS problems - it is only when a site can't be resolved or takes
an unusually long time to resolve that there are noticable hangs.)

Reproducible: Sometimes
Steps to Reproduce:
1. Find a website which has flaky DNS (not just one that doesn't exist, they
fail quite happily - one that does exist or did recently exist but is currently
not resolving through nslookup, although Firefox can sometimes find it anyway as
it seems to have a longer timeout)
2. Type in the URL or click on a link to said website.
3. Watch Firefox become unresponsive for up to a minute.
Actual Results:  
Firefox did not respond (window did not update properly, leaving other windows
on top, clearing completely to window background when minimised and maximised,
sometimes leaving mouse trails when cursors were animated ones) for 5-60
seconds. Often after that time the requested page loaded just fine - Firefox had
successfully managed the DNS resolution, when nslookup often just timed out instead.

Expected Results:  
Firefox should have stayed responsive whilst doing the DNS lookup in the background.

I am using a PAC file and can supply details of it if needed (there are some
other bugs about DNS resolution with PAC files, but they are all against older
versions and appear to be abandoned for reasons specifically to do with those
versions).
Reporter

Comment 1

15 years ago

Comment 2

15 years ago
I'm having the same problem.  I too am behind a proxy.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Comment 3

15 years ago
I have experienced similar behavior when a link opens in a new window.  I get
stuck on the new, blank, window until DNS resolves (after which I can switch to
other windows while the page loads).  I am on Windows NT4.

This also seems similar to older bug 237582.

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 237582 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.