DNS Resolution waits on a "dead location", preventing browsing until timeout.

RESOLVED DUPLICATE of bug 188332

Status

()

defect
RESOLVED DUPLICATE of bug 188332
15 years ago
14 years ago

People

(Reporter: josh, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040306 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040306 Firefox/0.8

I'm not exactly sure how to describe it, as I don't even fully understand it.  I
think this has reported before, but the existing reports didn't seem to fit the
problem I'm experiencing completely.

When visiting a location that contains a host that cannot be resolved, the
browser will wait for that while preventing any other browsing to continue.  For
example, visiting a site that contains an image from a host that cannot be
resolved, the browser will wait for the resolution and prevent you from being
able to browse other sites in the meantime (new tabs, new windows).  I'm
experiencing this in both Mozilla and Firefox on both Linux and FreeBSD. This
bug is considerably frequent.



Reproducible: Always
Steps to Reproduce:
1. Visit a site that contains a link to an unresolvable host.
2. If the host is not resolving, attempt to browse another location.
3. Other locations are unresolvable until the 'dead host' times out.

Actual Results:  
All browsing is halted while the 'dead host' is being resolved (waiting for
timeout).

Expected Results:  
Attempt to resolve the 'dead host' in the background, while still allowing browsing.

I don't currently have a URL that'll produce this issue.  I've produced it by
visiting http://bsdforums.org , http://www.onlamp.com , and others. It seems
consistant with sites that link to advertisement sites, such as ads.doubleclick.net

Comment 1

15 years ago
sounds like bug 162871, but that was fixed some time ago. I know I've not seen
this for a long while...

Comment 2

15 years ago
The bug is in the 0.8 release, and the latest nighly build.
The sites mentioned do not have the bug for me, but this site does:

  http://www.nytimes.com/

The site hangs for a long time and could be due to a _reverse_ DNS lookup timeout.

The problem is much worse if Firefox is configured to use a proxy server,
in which case the whole browser hangs (other tabs/windows are unusable)
until it times out.  Without a proxy, only the effected window/tab hangs.
Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040407 Firefox/0.8

i have the exact same problem as the origional poster.

Except that when resolving dead locations, or locations that are slow at
resolving, all browser windows go dead, and no other surfing can be done. A
workaround is:

1. Close all browser windows and tabs
2. Wait for it all to resolve

What i expect to happen:

Have the FQDN be resolved in the background. This would stop the entire browser
from locking up. And allow other browsing to continue.

Comment 4

15 years ago
I'm running FireFox 0.8 on FreeBSD 5.2.1.  When I open several tabs, say the
first 10 links on news.google.com, all processes will be blocked by one or two
tabs stuck on a DNS lookup.  Even pages that are currently open or new tabs to
sites I've just been to are still blocked.  If I close the new tabs, all sites
are still blocked until dns times out.  This sounds like closed bug 70213, but
that fix has not been ported to 0.8/freebsd, or was not really fixed.

Cory

Comment 5

15 years ago
Big honking PITA ;-) Concpetually, DNS resolution needs to happen in a seperate
thread so as not to block. I know this is what the OS should be doing, but this
seems to happen all the time when browsing via a http proxy, which makes me
think  there is more to it. 

Either way, this has forced me to Konq for everyday browsing.

Comment 6

15 years ago
Seeing this bug all the time in 0.8 on Linux. Severity should be major; it
renders the browser essentially unusable.

Comment 7

15 years ago
I'm also getting this a lot on windows at work with a proxy and linux at home
without a proxy - with firefox 0.93 and mozilla as well.

It's very very annoying, enough to make me start considering a different
browser. The severity should be a LOT higher.

Comment 8

15 years ago
Just adding my two cents since I have seen this before on FreeBSD.  Any FreeBSD
user reporting this problem (inclusing the submitter) should update to 5.3 once
it is released.  FreeBSD's resolver library was problematic and fixed after
5.2.1 was released.  This was noted in 237084.  Thanks.

Comment 9

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317
Firefox/1.0.2

I'm running the above setup, and I get this problem ___all the time___.  It's
infuriating having to close Firefox completely everytime a DNS lookup stalls. 
I'm  going to load up *gasp* IE in the meantime :)

Comment 10

14 years ago
*** Bug 270877 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
*** Bug 289511 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
The big thing, that doesn't seem to be mentioned by the other commentators, is
that while resolving pages across a slow network, CPU usage goes up to 100%.

I don't care if tabs "hang" but taking down the rest of the machine with it is
not amusing. Can someone please add a priority and/or target milestone to this bug?

Comment 13

14 years ago

*** This bug has been marked as a duplicate of 188332 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.