Closed Bug 271057 Opened 15 years ago Closed 14 years ago

selection/find results shifted to the left if line contains Arabic LAM-ALEF

Categories

(Core :: Selection, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: maysara, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

in this page , which is encoded in cp-1256(Arabic) when searching for a word
starting with م MEEM or ذ THAL or ز ZEEN or ض DAAD the highlight skips some
letters or highlights the next letter with a shift of 1 or 3 letters , didnt
find that in UTF-8 encoded pages.

Reproducible: Always
Steps to Reproduce:
1.open website , set encoding Arabic windows 1256
2.ctrl+f
3.search for arabic م ذ ز ض , these correspond to L ~ > Q keys on the english
layout. and note the highlight .

Actual Results:  
a highlight isnt shifted when looking up مي thats م + anyother letter
No highlight when typing ذ , but adding ل (coreesponds to 'g' key) it does
the ز sometimes shifts (try find Next, ull see it shifting to a space) , 
DAAD ض shifts too sometimes , please try the Find next to see the diffrent results .

Expected Results:  
when typing any of the letters ,  it should have highlighted them correctly !
Confirming. This happens on UTF-8 encoded pages also.

From my testing, the problem only affects lines with LAM-ALEPH ligatures.

For example, if a line of Arabic text contains two LAM-ALEPH ligatures, the
search for an Arabic letter would find (i.e highlight) a letter or a space two
positions after the letter or word we're actually searching for.

see attached testcase for examples.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: highlight shifts or skips some arabic letters . → highlight shifts or skips some arabic letters
Attached file simplified testcase (obsolete) —
I made some tests about this, and I think I found out where the problem might be:
Arabic, rather than most other languages, has two typing ways for its
characters, when you type a character to search for, Gecko tries the find the
character, it finds both cases of the character (good) but replaces the original
character in the page with the character case you typed and highlights it.
There should be some work around for that: to highlight the character while
keeping its case.
(In reply to comment #3)

If you're using Windows, and Arabic letters are changing their form when
selected (e.g. medial to isolated) then you're probably seeing Bug 75011.

This bug is about the find feature.  
Summary: highlight shifts or skips some arabic letters → Find results shifted to the left if line contains Arabic LAM-ALEPH
Looks like this bug happens on all types of selections when there is a Lam-Alef
ligature on the same line.

I've been experiencing more and more annoyances because of this bug. Double
clicking words, the search the web for feature, and other types of selections
are messed up and shifted to the left (both the selection highlight boxes and
the selected text itself are affected).

The new testcase should exhibit this bug more clearly. Try selecting the word in
the middle and see, for example, the wrong "search web for" text added to the menu.

I'm upgrading severity and -> selection.
Assignee: firefox → selection
Severity: minor → normal
Component: Find Toolbar / FastFind → Selection
Product: Firefox → Core
Summary: Find results shifted to the left if line contains Arabic LAM-ALEPH → selection/find results shifted to the left if line contains Arabic LAM-ALEF
Version: unspecified → 1.7 Branch
Attached file a better testcase
Attachment #168778 - Attachment is obsolete: true
This bug is no longer reproducible after switching to a pango enabled firefox
using "ac_add_options --enable-pango".
Depends on: 214715
Version: 1.7 Branch → Trunk
Depends on: 308020
Fixed by bug 308020
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.