All users were logged out of Bugzilla on October 13th, 2018

Window positioning on multiple monitors: no localstore.rdf, browser window opens with titlebar under menubar

RESOLVED FIXED in mozilla1.3alpha

Status

()

P3
normal
RESOLVED FIXED
19 years ago
14 years ago

People

(Reporter: sfraser_bugs, Assigned: danm.moz)

Tracking

Trunk
mozilla1.3alpha
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When there is no persisted window position information, the browser window comes 
up in a bad position; the title bar of the window is partially obscured under the 
menu bar. To reproduce:

1. Trash your localstore.rdf in your profile directory.
2. Run Mozilla. Note that the first browswer window is badly positioned.
(Assignee)

Comment 1

19 years ago
Happens when the bounding rect around the multiple-monitor screen region extends 
above the main monitor. We want more intelligent handling of multiple screen 
systems. Targeting to my window sizing and positioning milestone gulag.
Status: NEW → ASSIGNED
Summary: Window positioning: when no localstore.rdf, browser window opens with titlebar under menubar → Window positioning on multiple monitors: no localstore.rdf, browser window opens with titlebar under menubar
Target Milestone: M18

Comment 2

19 years ago
*IGNORE* - massive spam changing open XPToolkit bug's QA contact to
jrgm@netscape.com
QA Contact: paulmac → jrgm

Comment 3

19 years ago
Mass moving M18 bugs to M19
Target Milestone: M18 → M19

Comment 4

19 years ago
mass-moving all bugs to m21 that are not dogfood+ or nsbeta2+ or nsbeta2-
Target Milestone: M19 → M21
(Assignee)

Updated

19 years ago
Target Milestone: M21 → Future
(Assignee)

Comment 5

15 years ago
I believe this was fixed long ago. See especially bug 162090 which should
constrain windows to always be positioned entirely onscreen. If it's not fixed,
someone else may want to pick this bug up since I no longer have access to a Mac.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: Future → mozilla1.3alpha

Comment 6

14 years ago
*** Bug 174331 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.