New/Navigator Window appears off-screen if 2nd monitor was used and then disconnected due to stored info in localstore.rdf file

RESOLVED DUPLICATE of bug 27126

Status

RESOLVED DUPLICATE of bug 27126
16 years ago
14 years ago

People

(Reporter: dmm, Assigned: asa)

Tracking

(Blocks: 1 bug)

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020814
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020814

I connected a second monitor to my mac, and moved the navigator window to
the 2nd monitor, and used it normally.  Then I quit the application,
diconnected the monitor, and when I restarted mozilla there was no navigator
window anymore.  Every time I started a new navigator window from
the file menu, nothing would appear, yet they would be listed under the "window"
menu.

Finally the idea occured to me that the geometry information might be
stored somewhere in a file.  So I found the:
/Users/USERNAME/Library/Mozilla/Profiles/default/cv4bre3s.slt/localstore.rdf
file, and I removed that.  Then I started up Mozilla again, the Navigator
window as back in place, but a lot of my preferences were gone.

So, I think to fix this you need to check the info in that file to see
if the geometry information is currently valid, and if not, use default
settings so that the initial navigator window will appear.

Reproducible: Didn't try

Steps to Reproduce:
1. Hook up 2nd monitor to computer
2. put navigator window on 2nd monitor
3. quit mozilla
4. disconnect 2nd monitor
5. start up mozilla


Expected Results:  
Mozilla should have determined that the geometry information in the
localstore.pdf file was no longer valid and used a reasonable default
value to display the navigator window on the currently existing geometry.

Comment 1

16 years ago
I'm pretty sure I've seen a bug filed about this already.
Keywords: qawanted
Summary: New -> Navigator Window appears off-screen if 2nd moniter was used and then disconnected due to stored info in localstore.rdf file → New/Navigator Window appears off-screen if 2nd monitor was used and then disconnected due to stored info in localstore.rdf file
Whiteboard: DUPEME

Comment 2

16 years ago
See bug 27126 and bug 99236

Comment 3

16 years ago
*** Bug 188375 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
*** Bug 211752 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 236647
Product: Browser → Seamonkey

Comment 5

14 years ago
Has this bug happened to anyone in the past year or so? If not, I'll dupe it to
bug 27126 (fixed).

Comment 6

14 years ago
No known recurrences in 2004.

*** This bug has been marked as a duplicate of 27126 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.