local images fail to display within html Editor

RESOLVED DUPLICATE of bug 122022

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 122022
13 years ago
13 years ago

People

(Reporter: Kurt Cagle, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0

In the XUL editor component, when an image tag is added into the HTML for the
contentDocument and the protocol of that image is file:///, the image does not
display and the bounding retangle for the image is set to 32x32. Normal HTTP
protocol works fine. The editor is intended to be used in a stand-alone mode
with or without internet connection.

Reproducible: Always
Steps to Reproduce:
1. Set the documentContent of an editor document to HTML that contains any file
reference (file:///C:/images/foo.jpg) or native app (such as windows
c:\images\foo.jpg).

Actual Results:  
An unresized (resizable)image container with no image,

Expected Results:  
Display the image at full size. 

This occurs with the default theme.

Comment 1

13 years ago
Related to bug 69070?

Comment 2

13 years ago
Better ways as comment 3 is to use it only for a particular site, see Bug 233108.

This is not allowed to Bug 69070 for security reasons, see bug 268778 comment 3.

See bug 122022/bug 84128.

*** This bug has been marked as a duplicate of 122022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.