Keyboard shortcut descriptions can be incorrect if user pref is set

RESOLVED WONTFIX

Status

Firefox Graveyard
Help Documentation
--
minor
RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: Waldo, Assigned: Jeff Walden (gone starting June 8))

Tracking

Details

(Reporter)

Description

14 years ago
There's now a pref to set what happens when Ctrl+Enter is hit in the location
bar.  It was load "http://www."+<text>+".com/", but now it's a pref for
localizers to fiddle with should they desire to do so.  The format of the fix
for us should be roughly similar to the fix for the bug itself.  (We'll need to
be careful how to add the text, tho, as document.write is invalid in XHTML --
adding a wrapper <span/> element containing the proper text is how it'll have to
be done.)

Note that the bug itself has only fixed the Ctrl combo, when comments suggest
that other modifier combos need similar fixes.

Comment 1

14 years ago
>but now it's a pref for localizers to fiddle with should they desire to do so

Localizers who will change this pref will (probably) translate help too. Why not
simply add other help Entity for them. Isn't it suitable? (not automatic but
simple). Or we need automatic solution?
(Assignee)

Comment 2

14 years ago
I've tried doing this, and the script isn't allowed to read the preference.  The
privs are wrong, and this was intended to be a quick-and-easy bug.  If someone
else figures out a method *and* posts a working patch, reopen.

-->WONTFIX
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.