Plugin download dialogue keeps bothering you when using the mouse-wheel

RESOLVED DUPLICATE of bug 270377

Status

RESOLVED DUPLICATE of bug 270377
14 years ago
14 years ago

People

(Reporter: aceop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

In the moment they have a big flash on the right side of the mentioned website
http://www.spiegel.de/; as I didn't install the plugin (or rather, the system
administrator didn't) I don't see anything but the placeholder for unknown content.

Every time I use the mouse-wheel and erraneously come over the flash (happens
even more often on pages where the flash is positioned somewhere else on the
page) the "default plugin" dialog will pop up and bother me.

Actually I have no idea if this is Mozilla's fault or if the default handling of
the mouse-wheel on SuSE8.2/KDE3.1.1; if it's Mozilla's fault, it'd be nice if
there was a "never download the plugin for this MIME-type" box to make the
default plugin dialog shut up forever.

I have no idea if this also happens under Windows - if it does I suppose it's a
real bug as this behaviour will make the people install all kinds of plugins
just to get rid of the plugin-dialog.

Reproducible: Always
Steps to Reproduce:
1. Use the mouse wheel to scroll down on the page http://www.spiegel.de while
having the mouse-pointer positioned over the flash on the right
2. "default plugin" dialog pops up

Actual Results:  
The default plugin dialog pops up each time I use the mouse wheel over a
plugin-content spaceholder for content I have no plugin for

Expected Results:  
The default plugin dialog should remember if it asked me before if I wanted to
download the plugin and don't ask me again.

Comment 1

14 years ago
just remove or rename the null plugin, it is responsible for offering
installation of missing plugins.
On windows that is npnul32.dll in the plugins folder.
(Reporter)

Comment 2

14 years ago
Well, under Unix I had success with editing the "do-not-edit" file
.mozilla/pluginreg.dat and replacing the path to the null-plugin with /dev/null.

But anyway, that's not the perfect solution for the problem, I suppose.
(Reporter)

Comment 3

14 years ago
Ehmmm... trash my last comment. Doesn't work, I didn't test sufficiently.

Comment 4

14 years ago
It's a dupe of #270377 where I attached a patch to fix this unfriendly behaviour.

*** This bug has been marked as a duplicate of 270377 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.