Add user dropdowns to editcomponents.cgi

RESOLVED FIXED in Bugzilla 2.20

Status

()

--
enhancement
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

2.17.7
Bugzilla 2.20
Bug Flags:
approval +

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-gb) AppleWebKit/125.5.5 (KHTML, like Gecko) Safari/125.11
Build Identifier: 

editcomponents was not templatized when the user dropdown code was added to bugzilla, but it is 
now, so we can add the user dropdown

Reproducible: Always
Steps to Reproduce:
*** Bug 272659 has been marked as a duplicate of this bug. ***
Getting user matching to work here would be Really Cool, too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

14 years ago
Created attachment 167585 [details] [diff] [review]
Add the user dropdown to editcomponents

[Grr, blooming safari timeout and resubmit a duplicate bug grr..]

And yes, I'll try and add the user matching as well as this user dropdown at a
later date (there is already a bug for that)
Assignee: justdave → bugzilla
Status: NEW → ASSIGNED
(Assignee)

Comment 4

14 years ago
Comment on attachment 167585 [details] [diff] [review]
Add the user dropdown to editcomponents

Byron: This is extracted from a larger patch on bug#255425 which you looked at
a long time ago, to add the user dropdown to editcomponents. Could you review
sometime please?
Attachment #167585 - Flags: review?(bugzilla)
Comment on attachment 167585 [details] [diff] [review]
Add the user dropdown to editcomponents

r=glob
Attachment #167585 - Flags: review?(bugzilla) → review+
Flags: approval?
holding approval for creation of the 2.20 branch (this will go on the trunk
after we branch)
Target Milestone: --- → Bugzilla 2.22

Updated

14 years ago
Whiteboard: patch awaiting approval

Comment 7

14 years ago
Targeting bug to 2.20 since the 2.20 feature freeze was canceled.
Target Milestone: Bugzilla 2.22 → Bugzilla 2.20
Flags: approval? → approval+

Comment 8

14 years ago
GavinS: https://bugzilla.mozilla.org/show_bug.cgi?id=255428 got checked in. Do
you still want this in the CVS?
Whiteboard: patch awaiting approval
(Assignee)

Comment 9

14 years ago
Created attachment 171447 [details] [diff] [review]
add user dropdown to editcomponents

Updates patch to tip, and adds the 'id=' field to the dropdown and non dropdown
case
Attachment #167585 - Attachment is obsolete: true
Attachment #171447 - Flags: review?(bugzilla)

Comment 10

14 years ago
Gavin: I was talking about the multiple => 5 thing.
(Assignee)

Comment 11

14 years ago
(In reply to comment #10)
> Gavin: I was talking about the multiple => 5 thing.

I don't think that applies to this editcomponents patch does it? (Or am I
missing something?)


Comment 12

14 years ago
True, you're right, sorry about that.
Comment on attachment 171447 [details] [diff] [review]
add user dropdown to editcomponents

sorry about the delay in looking at this.

checkin for bug 266579 breaks the userselect.html.tmpl change :(
Attachment #171447 - Flags: review?(bugzilla) → review-
(Assignee)

Comment 14

14 years ago
Created attachment 172036 [details] [diff] [review]
add user dropdown to editcomponents

Updated to tip
Attachment #171447 - Attachment is obsolete: true
Attachment #172036 - Flags: review?(bugzilla)
Comment on attachment 172036 [details] [diff] [review]
add user dropdown to editcomponents

r=glob
Attachment #172036 - Flags: review?(bugzilla) → review+

Comment 16

14 years ago
Checking in template/en/default/admin/components/create.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/components/create.h
tml.tmpl,v  <--  create.html.tmpl
new revision: 1.2; previous revision: 1.1
done
Checking in template/en/default/admin/components/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/components/edit.htm
l.tmpl,v  <--  edit.html.tmpl
new revision: 1.3; previous revision: 1.2
done
Checking in template/en/default/global/userselect.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/userselect.html.tm
pl,v  <--  userselect.html.tmpl
new revision: 1.4; previous revision: 1.3
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

10 years ago
Blocks: 465803
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.