The Print Selection Only checkbox in the PrintPDE.plugin is in some cases always disabled

Status

()

Core
Printing: Output
13 years ago
4 years ago

People

(Reporter: Marcello Testi, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

(Blocks: 1 bug)

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X

Is this feature is implemented, it should work as expected, otherwise, remove
the checkbox and its label.

Reproducible: Always
Steps to Reproduce:
1. Load a web page
2. Select some text
3. Select File -> Print... menu item
4. In the second dropdown menu in the Print dialog, select "Camino"

Actual Results:  
The Print Selection Only checkbox is disabled

Expected Results:  
The Print Selection Only checkbox should be enabled

Comment 1

13 years ago
It works for me, note that the selection only is frame related and has nothing
to do with selected text and images on a regular page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Summary: The Print Selection Only checkbox in the PrintPDE.plugin is always disabled → The Print Selection Only checkbox in the PrintPDE.plugin is always disabled
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> It works for me, note that the selection only is frame related and has nothing
> to do with selected text and images on a regular page.

So, it should go near the frames prefs, not on top of the dialog. I also suggest
a label change: Print only selected frame.
I'm opening another bug for this.

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

13 years ago
It works for me, but Marcello is till having the issue strangly enough

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: Printing → Printing
Ever confirmed: true
Product: Camino → Core
Summary: The Print Selection Only checkbox in the PrintPDE.plugin is always disabled → The Print Selection Only checkbox in the PrintPDE.plugin is in some cases always disabled
Version: unspecified → Trunk
(Reporter)

Comment 4

13 years ago
It all ended up being an issue with custom printing presets. Confirmed for all
current Camino builds, but also other products (tested and verified in Firefox).
See bug 272746
QA Contact: printing

Updated

7 years ago
Blocks: 272746
You need to log in before you can comment on or make changes to this bug.