Deleting an address book card (that is contained in some mailing lists) from the address book results in changing the card instance in the mailing list into an empty card instead of deleting

RESOLVED DUPLICATE of bug 152133

Status

Thunderbird
Address Book
--
minor
RESOLVED DUPLICATE of bug 152133
13 years ago
13 years ago

People

(Reporter: Fenix, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird1.1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Suppose having an address book that contains an unempty mailing list (e.g. an
address book named "Friends," inside it a list named "classmates" containing
cards "George" and "Will") . If a card that is contained inside the distribution
list (e.g. "Will" inside "Classmates") is deleted the from the parent address
book (from "Friends,") its instance inside the list ("Classmates") is not
deleted. Despite an empty card (without any items filled) remains inside the
list (now containing "George" and "_") 

Reproducible: Always
Steps to Reproduce:
1. Create an address book and an unempty distribution list inside it. (e.g. an
address book named "Friends," a list named "classmates" containing contacts
"George" and "Will") 
2. Delete "Will" from the address book (from "Friends" not from the the
"Classmates" list)

Actual Results:  
The "Classmates" mailing list still containins two cards: "George" and "_" - an
empty one.

Expected Results:  
The deleted card ("Will") should have been deleted also from the mailing list.

Comment 1

13 years ago
I would say this is a duplicate of Bug 152133. Suite and TB share a lot of AB code.
Whiteboard: DUPEME
This bug should be fixed by the patch I've just attached to bug 152133, adding
dependence and will revisit once that one is checked in and marked as fixed.
Depends on: 152133
The patch for bug 152133 went in earlier today, I have rechecked the latest
trunk version of thunderbird and this now works - therefore marking as a
duplicate of bug 152133 as that seems most appropriate.

*** This bug has been marked as a duplicate of 152133 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Target Milestone: --- → Thunderbird1.1
You need to log in before you can comment on or make changes to this bug.