Last Comment Bug 273071 - Mailto links are controlled by GNOME prefs, even in KDE
: Mailto links are controlled by GNOME prefs, even in KDE
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Blake Ross
:
:
Mentors:
: 266781 434027 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 18:34 PST by Richard Neill
Modified: 2010-09-18 02:40 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Richard Neill 2004-12-03 18:34:53 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041127 Firefox/1.0

Clicking on a mailto: link ought to open my default mail client under KDE. 

It doesn't. Fortunately, I guessed that the answer is to open the
gnome-control-center from the command line, even though I don't use gnome.

A newbie could never fix this, especially since Mandrake hide GNOME-specific
items from the KDE menu.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
It should detect that I'm running KDE and use KDE's mailto handler. 

Also, firefox should have a preference setting to control this (even if the
preference setting simply says "this uses the system-wide config in
gnome-control center")

Ideally, I'd like a config option to choose between:

Applications: Thunderbird, 
              Mozilla Mail
              Evolution
              Kmail

GUI defaults: GNOME
              KDE

Command line  [ /usr/local/bin/mymailclient %s ]

In this case, firefox makes 2 mistakes.

  * It doesn't follow the principle of least surprise.

  * The control isn't in the obvious place (Edit->Preferences)
Comment 1 Mike Connor [:mconnor] 2004-12-03 18:58:57 PST
we really need a place for gathering KDE integration bugs that no one will ever
fix.  That isn't meant to be harsh, but the people and companies working on
Linux bits are all GNOME-oriented, and no one seems interested in a KDE port for
Firefox.
Comment 2 Richard Neill 2004-12-03 19:14:32 PST
KDE integration per se isn't (imho) the important thing. 
But it's a serious bug if the GNOME-ness isn't explicit, so that a user cannot
fix it.

(BTW, another GNOME thing is use of GNOME prefs for anti-aliasing. Personally, I
dislike antialiasing  - I'd much rather have decent, non-scaled fonts.)

Comment 3 Mike Connor [:mconnor] 2004-12-03 20:04:38 PST
ultimately, we're a GTK2-based app, so using GNOME prefs is a logical next step.
 Maybe we should add something in the release notes making this more clear, I'll
float the idea.
Comment 4 Stefan Seifert 2005-07-14 10:43:07 PDT
Could someone explain to me why we have here a wonderful platform independent
application but restrict Linux users to one special desktop environment? Doesn't
make sense to me and I'd guess it won't for all those KDE users that will never
discover that mailto: links could actually work in Firefox. Not to speak of
those who have a slimmed down system for various reasons and simply don't need a
fat desktop environment alltogether.
Comment 5 Jonah 2005-08-28 13:03:54 PDT
(In reply to comment #4)
> Could someone explain to me why we have here a wonderful platform independent
> application but restrict Linux users to one special desktop environment? Doesn't
> make sense to me and I'd guess it won't for all those KDE users that will never
> discover that mailto: links could actually work in Firefox. Not to speak of
> those who have a slimmed down system for various reasons and simply don't need a
> fat desktop environment alltogether.

this sucks! can we please have this fixed firefox!!
Comment 6 Mike Connor [:mconnor] 2005-09-03 11:16:08 PDT
To reiterate what I've said, in many places, at many times, for better or worse
we're on the GTK2/GNOME integration train.  We're not that platform independent,
we pick up GTK themes, and GTK button ordering, among other things.

To respect KDE prefs, we'd need an integration layer with KDE, and we'd want to
use KDE dialogs, and KDE theming, etc.  There's a port for QT, it was back on
track at one point, but I'm not sure where that's going.  Once its
production-ready, a Firefox KDE port is feasible, but until then we're basically
a GNOME/GTK2 app, like it or lump it.
Comment 7 Mike Connor [:mconnor] 2006-08-27 05:20:32 PDT
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
Comment 8 Richard Neill 2006-08-27 09:45:50 PDT
There is an easy workaround: add this to about:config.
  network.protocol-handler.app.mailto =  /usr/bin/thunderbird  
However, there really ought to be a GUI for this. 

This bug is most definitely valid, and it is ludicrous that, by default, Firefox doesn't pair with thunderbird!
Comment 9 Samuel Sidler (old account; do not CC) 2007-04-03 10:13:15 PDT
*** Bug 266781 has been marked as a duplicate of this bug. ***
Comment 10 Kevin Brosnan 2008-05-16 05:32:20 PDT
*** Bug 434027 has been marked as a duplicate of this bug. ***
Comment 11 Ladislav Nesnera 2008-05-21 04:25:24 PDT
(In reply to comment #8)
> There is an easy workaround: add this to about:config.
>   network.protocol-handler.app.mailto =  /usr/bin/thunderbird  
> However, there really ought to be a GUI for this. 
> 
> This bug is most definitely valid, and it is ludicrous that, by default,
> Firefox doesn't pair with thunderbird!
> 

This technique works for me in FF 2.x. I'm use FF 3 rc1 with the same setting for network.protocol-handler.app.mailto and it doesn't work :(  (I have Kmail)

Note You need to log in before you can comment on or make changes to this bug.