Last Comment Bug 273171 - Text 'tref' not supported
: Text 'tref' not supported
Status: RESOLVED INVALID
: testcase
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal with 13 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://www.w3.org/Graphics/SVG/Test/2...
: 430485 826123 (view as bug list)
Depends on:
Blocks: svg11tests
  Show dependency treegraph
 
Reported: 2004-12-04 13:30 PST by jonathan chetwynd
Modified: 2014-06-02 22:34 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description jonathan chetwynd 2004-12-04 13:30:46 PST
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041125
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041125

http://www.w3.org/TR/SVG11/images/text/tref01.svg

'Referenced character data' is not displayed should be in "red"

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Ivan G Shevchenko 2007-12-08 16:15:12 PST
that's a missing feature (an important one IMHO). shouldn't this bug's severity be made major?
Comment 2 Sylvain Pasche 2008-04-23 15:21:29 PDT
*** Bug 430485 has been marked as a duplicate of this bug. ***
Comment 3 Manuel Strehl 2010-02-23 10:32:42 PST
Just to ping this one again (to celebrate its 5th birthday). Actually, IMHO this should be quite a fast fix (although I have no clues of the Gecko internals, I might therefore be totally wrong).

Why a fast fix? From my reading of the spec it seems as if <tref/> is nothing else than a <use/> in disguise, and the latter is almost fully implemented. The only difference is, that <use/> uses all referenced DOM elements while <tref/> uses all CDATA.
Comment 4 Helder "Lthere" Magalhães 2010-02-24 01:48:04 PST
Some have lately blogged [1] [2] about the wish to suppress this from SVG future. I also have never used this potentially neat feature, but mostly because of lack of support (if Firefox, at least).

I'm not claiming that priority should be increased/decreased, I'm just throwing these links in the hope of being useful. :-)

Actually, I find this feature interesting in the scope of declarative SVG (read: non-scripted) but potentially superseded by the params proposal [3] [4]?

[1] http://berjon.com/blog/2010/01/svg2.0-wishlist.html
[2] http://www.codedread.com/blog/archives/2010/01/29/svg-2-0-wishlist/#slicing-not-chopping
[3] http://www.w3.org/TR/SVGParamPrimer/
[4] http://www.w3.org/TR/SVGParam/
Comment 5 Robert Longson 2013-01-03 02:44:54 PST
*** Bug 826123 has been marked as a duplicate of this bug. ***
Comment 6 Cameron McCormack (:heycam) 2014-06-02 22:34:58 PDT
The SVG Working Group recently resolved to remove <tref> from the spec.

http://www.w3.org/2014/05/08-svg-minutes.html#item02

Note You need to log in before you can comment on or make changes to this bug.