Change mail folders format to maildir

VERIFIED DUPLICATE of bug 58308

Status

enhancement
VERIFIED DUPLICATE of bug 58308
15 years ago
15 years ago

People

(Reporter: vascopinheiro, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I think mail folders format should be maildir format rather then mbox, because
it would be faster when looking into a folder with thousands of messages. And it
would be easier do fix any problem with a bad email, by deleting one email
message file, rather than search a big email file for the content for that email
message.

Reproducible: Always
Steps to Reproduce:
1. Have many emails on one email folder
2. Selected that folder
3. 

Actual Results:  
Watch the machine to be processing a large file to display the messages headers,
and after it, to open each message.

Expected Results:  
Opening the folder should be faster if the messages are separated into diferente
files, like maildir format style.
Please search before you bugs, very easy to find with "maildir" as search term

*** This bug has been marked as a duplicate of 58308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Change mail folders format to maildir → Change mail folders format to maildir

Comment 2

15 years ago
verifying the dup - but be aware that the reasons you give for using maildir are
not really valid - opening a message in a large folder just does a file system
seek to the offset of the message in the file, which is almost as fast as
opening a stand-alone file, and deleting a message in a large mailbox is just a
matter of updating a byte in the message; that will probably be faster than
deleting a file from the file system.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.