PAC: loading PAC file w/ redirect slower than homepage request

VERIFIED DUPLICATE of bug 100022

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 100022
13 years ago
13 years ago

People

(Reporter: John Manning, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; FunWebProducts; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

automatic configuration does not complete loading PAC file before requst for 
homepage starts when PAC is hosted on a redirect.

We have a large implimentation of automatic configuraiton (150K users) and use 
a single URL with an application that redirects the request to the proper .PAC 
file for he requesting ip.  This system has worked well for 5+ years.

I have found that Firefox, and I think older versions don't wait for the 
loading of the PAC to finish before attempting to load the homepage.  
Subsequent request in the borwser session work fine, so obviously the pac load 
does complete.

This is most easily seen using a sniffer.  Its also intermitent, if the web 
server hsoting the PAC files response fast enought it gets the pac loaded 
before the request for the homepage.  All of this happens in under a second, 
this is not a slow server issue.

Its pretty easy to reproduce for us, more often then not we can make it fail.

Wuold be happy to help in any way.  
Cheers
John

978-506-4662

Reproducible: Always
Steps to Reproduce:
1.configure a pac file behind 2 redirects code a 1 second pause in the second 
redirect then go to the pac.
2.open the browser and it will fail to load the home page.  Look at a network 
capture and you'll see it make the homepage request while waiting for the 
response of the redirected.

Note: you don't need 2 redirects, this will just garentee you a failure.  We 
jsut point to a host on the other side of the glob and it fails. 
Actual Results:  
if fails

Expected Results:  
wait till the pac file is finished loading to request the homepage.

I could walk someone thru this ASP if intereste.  I can also send the network 
captures.  Here is an example of an ASP page that would pause before returning 
the PAC after a redirect.

ASP .. I know. I should have done it in perl.

Dim i
Dim x
If IsEmpty(Request("redirected")) Then
	response.Redirect("redirecttest.asp?redirected=true")
Else
	For i = 1 to 1000000
		x = x + i
	Next
	response.Redirect("proxy.pac")
End If

*** This bug has been marked as a duplicate of 100022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
V/dupe. There is a FF bog on this already. Please look at bug 208828, and let me
know if the summary needs improvement.
Status: RESOLVED → VERIFIED
QA Contact: general → benc
Summary: automatic configuration does not complete loading PAC file before requst for homepage starts when PAC is hosted on a redirect → PAC: loading PAC file w/ redirect slower than homepage request
You need to log in before you can comment on or make changes to this bug.