If first line of msg is '--', entire message is detected as a sig and quoting problems are introduced

RESOLVED DUPLICATE of bug 54570

Status

--
minor
RESOLVED DUPLICATE of bug 54570
14 years ago
14 years ago

People

(Reporter: chiller255, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If a msg begins with -- on a single line, the entire message will appear as a
signature (greyed-out).  Likewise, attempting to reply to this message with
quoting enabled will NOT quote the message.

Reproducible: Always
Steps to Reproduce:
1.  Send a mail to yourself with the first line as '--' and some text thereafter.
2.  View the message--it's all greyed out.
3.  Enable auto quoting of replies.  Click the reply button.

Actual Results:  
The contents of the composition are simply:

[sender] wrote:



Expected Results:  
If the first line of the file is '--', assume that this is NOT a signature and
do not grey out the message.  Replying with quoting enabled will quote the
entire message.

Workaround:  select the entire greyed-out message, then paste-as-quotation
within your reply.
(Reporter)

Comment 1

14 years ago
(this is thunderbird 1.0 btw)

Comment 2

14 years ago
Do you mean '--' or '-- '? Only '-- ' is seen as valid signature sign ('--' is
only produced by broken mail clients). If you mean '-- ', i still don't think
there should be a excerpt from the treat-as-signature rule here. Maybe someone
wants to send a empty mail with his signature to hisself to do some testing?
(Reporter)

Comment 3

14 years ago
You're right, it's '-- ' not '--'.  I've sent emails to myself to confirm this.
 Why someone would send an email like this, I have no idea, but I received one.

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 54570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.