Incoming mails with date in the future

RESOLVED DUPLICATE of bug 216033

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 216033
14 years ago
14 years ago

People

(Reporter: Charlie, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: version 0.9 (20041103)

Since I am using Thunderbird I am receiving mails with date and/or time stamp
which is in the past. E.g. today is Sunday, Dec. 12 2004 5:37pm and I received
mail with following date and time:
12/13/2004 12:09am


In the first line of the header information you can see when the message was
received and further down in the header the date is in the future.
Here is the header information of that message:
-----------------
From - Sun Dec 12 17:24:50 2004
X-Account-Key: account2
X-UIDL: 7c5d6143b0b30f024f9f9646b0bdb721
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-Path: <archimedes@nd.edu>
X-Flags: 0000
Delivered-To: GMX delivery to spearfisher@gmx.net
Received: (qmail 29901 invoked by uid 65534); 12 Dec 2004 22:14:12 -0000
Received: from 11.red-62-57-235.user.auna.net (HELO nd.edu) (62.57.235.11)
  by mx0.gmx.net (mx050) with SMTP; 12 Dec 2004 23:14:12 +0100
From: <archimedes@nd.edu>
To: <spearfisher@gmx.net>
Subject: Cheapest meds you'll find.
Date: Mon, 13 Dec 2004 00:09:14 -0500
Message-ID: <20041212221413.29918gmx1@mx050.gmx.net>
X-GMX-Antivirus: -1 (not scanned, may not use virus scanner)
X-GMX-Antispam: -2 (not scanned, spam filter disabled)
X-Antivirus: AVG for E-mail 7.0.289 [265.4.8]
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
-----------------


Reproducible: Sometimes
Steps to Reproduce:
This does not happen with all emails I receive.
Only with some of them and as far as I observed this problem it only happens
with SPAM emails.
I never had that problem with other email clients


Expected Results:  
Show the date when my email was received.
This is by design. Mozilla and TB displays the date from the email header (set
by the sender) and the header in this example mail is :
Date: Mon, 13 Dec 2004 00:09:14 -0500

You are GMT+1 and that makes a 6h difference and the result is what Thunderbird
displays.

THere are 2 mathcing RFEs for this, bug 216033 and bug 194585.

*** This bug has been marked as a duplicate of 216033 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.