The default bug view has changed. See this FAQ.

When dragging text to search bar, mouse over search engine should show list of search engines, and allow dropping text onto one to search that engine

NEW
Unassigned

Status

()

Firefox
Search
P3
enhancement
Rank:
33
13 years ago
8 months ago

People

(Reporter: Ian Macfarlane, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

(Reporter)

Description

13 years ago
When selecting some text and dragging it to the search bar, hovering the mouse
over the search engine icon should display the drop down list of search engines,
and releasing the mouse over that search engine should instead search for that
selected text in that engine.

I don't think this would confuse most users just searching, as they usually
don't drag text there when searching so they wouldn't notice this, but for
advanced users this would be very, very cool. It might be an idea to perhaps
have a small (0.5/1 second or so) delay before opening this up.

We'd obviously want to hide the "Add Engines" from the list when dragging text
like this to the search box, and perhaps other small visual things could be done
(for example change the text for "Google" to "search Google" or even "search
Google for <start of text ending with... after X characters>". Or perhaps have a
heading at the top of the search engines list that says something like "search
these engines for <dragged text...>" - just to keep it all tidy.

Comment 1

12 years ago
*** Bug 296360 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This makes it far to complicated for non-geek users

->WONT
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

12 years ago
It doesn't make it complicated at all for non-geek users. As I stated, due to
the delay before being shown, it won't get shown at all unless the user hovers
over the icon for long enough.
This is a quite reasonable request.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: p_ch → nobody
OS: Windows 2000 → All
Version: unspecified → Trunk
Keywords: helpwanted
(In reply to comment #3)
> This makes it far to complicated for non-geek users
> 

I don't think it will be complicated for non-geek users, as it usually will go unnoticed for them, as well as the dragging link to the bookmarks menu, the tabs or the url bar...

Nevertheless for power-users, it will enhance the experience avoiding to go twice to the same place (selecting the search engine and dragging the text to search).


I think it would be a nice enhancement to the works being done on the search bar for FF2.0
I also agree with this feature, its very useful.
Assignee: nobody → gavin.sharp
Keywords: helpwanted
Priority: -- → P2
Target Milestone: --- → Firefox 3 alpha2
Status: NEW → ASSIGNED

Comment 9

10 years ago
I implemented this feature as an extension. It possibly helps you to imagine the behavior of future Firefox including a fix of this bug.

http://piro.sakura.ne.jp/xul/_secondsearch.html.en (Ver.0.3.2007050202 or later)
(In reply to comment #9)
> I implemented this feature as an extension. It possibly helps you to imagine
> the behavior of future Firefox including a fix of this bug.
> 
> http://piro.sakura.ne.jp/xul/_secondsearch.html.en (Ver.0.3.2007050202 or
> later)

I tried this on the Mac a little while ago and wasn't able to make it work. Is it Windows or Linux-only?

Comment 11

10 years ago
In Mac, the popup can be shown just after you drop the text to the bar.
Its implementation is based on codes from the "Bookmarks" menu.
(It popups the menu if you drag-over onto the menu, in Windows or Linux.
It also doesn't work in Mac.)
Target Milestone: Firefox 3 alpha2 → Firefox 3 beta1
Not working on this at the moment. Hiroshi, maybe you would be interested in creating a patch?
Assignee: gavin.sharp → nobody
Status: ASSIGNED → NEW
Priority: P2 → --
Target Milestone: Firefox 3 M7 → ---

Comment 13

5 years ago
This worked for many years now, but now it's broken (at least on linux, but I think also on windows).

Sorry I don't know how I should handle to change the status to BUG

Updated

2 years ago
Priority: -- → P3
Whiteboard: [fxsearch]

Updated

2 years ago
Rank: 33

Comment 14

10 months ago
The one-off search provides a popup panel to list available search engines. It seems very similar to a part of this bug. Now, I hink that we only have to write some codes to handle drag and drop on the search bar. Is it the time?

Comment 15

10 months ago
And I've confirmed that the one-off search popup appears after I drop a text. But I still need dragover!
You need to log in before you can comment on or make changes to this bug.