Need to click 'Next' button and OK twice to advance to another folder

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Luiz Carlos Maciel Jr., Assigned: Scott MacGregor)

Tracking

x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
I'm using Thunderbird 1.0 (20041206) with 9 email accounts configured and around
50 folders and subfolders under "Local Folder".
I use the toolbar's "next" button to read my messages.
After i read the last unreaded message in any folder, i click "next" button and
it asks me if i want to advance to next unread message in ???? folder. I click
"OK", the window close and nothing happens.
Then i immediately click on "next" button again, it asks, again, if i want to
advance to next unreaded message in ??? folder. I click  on "OK" and now i go to
next unreaded message in ??? folder.

Comment 1

13 years ago
this works for me - when you say ???? and ???, you mean the same folder, right?
Is it possible that the summary file is missing or out of date for the ????
folder? Does this happen all the time, or just sometimes?
(Reporter)

Comment 2

13 years ago
No, different folders. I'll try to explain again.
I'm reading mail from folder "a" and, using the "next" button, reach the end of
unreaded messages. Then i click "next" button and the window opens asking me if
i want to advance to next unreaded message in folder "b". I click "Ok", the
window closes and nothing happens. Then i click "next" button again and now i go
to folder "b", in the first unreaded message.
I'm sure that the summary file is not missing and it is up to date.
This happens every time i reach the end of unreaded messages in a folder and
still have messages unreaded in another folder.

Comment 3

13 years ago
This bug is also affecting me.  I'm using Thunderbird 1.0.2 (20050317) on
Windows 2000 SP4.

I originally thought this problem *might* have been caused by an extension I
had, but after disabling all extensions by running Thunderbird in Safe Mode with
this profile, this problem still exists:

If I'm reading a message in one folder, and have an unread message that's in a
different folder, I have to click twice on the "Move to next unread message"
button (as the first click does nothing) in order to go to the unread message in
the other folder.

Comment 4

12 years ago
This bug affects me as well. I use Thunderbird 1.0.6 on Windows XP. I have a 
total of 4 incoming mail folders in Thunderbird. This problem occurs when I 
open the first unread message in a separate window and then advance through 
the next unread messages with either the space bar or the "n" key. This 
problem does _not_ occur when I advance through the unread messages in preview 
mode (three-pane view). This difference in behavior between three-pane view 
and full-window view may explain why not everyone was able to reproduce this 
bug.

Comment 5

12 years ago
Resummarizing; confirming based on bug I'm about to dupe here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Next button needs 2 clicks on "OK" to read next unreaded message on another folder → Need to click 'Next' button and OK twice to advance to another folder

Comment 6

12 years ago
*** Bug 286921 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
Also a bug for me. XP Pro, Thunderbird 1.5.0.2. After reading all messages in folder, I press "n" (BTW this of course only works on lower-case "n", never for upper-case, which could be fixed!) and am asked to advance. I press Enter key, and nothing happens. I press "n" again and am asked, and press Enter, and this time, it goes to next unread message in whatever folder is next. 
Reproduceable: always happens this exact way!

Peter Brown
peterbbrown@charter.net
      

Comment 8

11 years ago
There is a partial workaround: add

user_pref("mailnews.nav_crosses_folders", 0);

to prefs.js or user.js in the Thunderbird profile directory.

This advances to the next folder unconditionally, i.e. you get no
prompt instead of two prompts. Not ideal, but not quite as irritating.

Comment 9

11 years ago
(In reply to comment #8)
> There is a partial workaround: add
> 
> user_pref("mailnews.nav_crosses_folders", 0);
> 
> to prefs.js or user.js in the Thunderbird profile directory.

Actually, space or 'n' is still ignored the first time you cross
folders; it's just that you get no prompt on either the ignored
keypress, or the keypress that works.

Updated

11 years ago
Blocks: 370090
QA Contact: front-end

Comment 10

11 years ago
I don't see this problem any more in Thunderbird 2.0.0.4. Is it completely fixed?

Comment 11

11 years ago
I'm going to take David's word on this and resolve as WORKSFORME. If anyone can still reproduce in Thunderbird 2.0.0.x, please reopen.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.5
You need to log in before you can comment on or make changes to this bug.