Closed Bug 27477 Opened 20 years ago Closed 20 years ago

[FEATURE] Make Mozilla about: page legal

Categories

(SeaMonkey :: General, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mcafee, Assigned: mcafee)

References

()

Details

(Whiteboard: [PDT+] MUST FIX: 2/25 email sent about mozilla trademark to btoring.)

Mozilla version of bug 10980.

Make the Mozilla about: page legal,
proper icons & stuff is icing.
Keywords: beta1
Target Milestone: M14
Status: NEW → ASSIGNED
Adding mitchell for legal help.
Q1: Do we need MPL in about: ?  NPL is there right now.
Q2: Shouldn't we be (c) 1998-2000 like the rest of mozilla.org
    content pages?
Mitchell and I just talked this over a bit, and she's meditating on the best way
to do this.
Putting on the PDT+ radar for beta1.
Whiteboard: [PDT+]
I rewrote text, dmose has for review.  Added the MPL.  Changed the wording to 
reflect fact that there are numerous Initial Developers.  Agree with dmose's 
suggestion that we should link to a list of Contributors rather than try to 
include them in the About: page; there are too many for this now.
dmose: either attach new license text here, or send me email.
Blocks: 10980
Added URL to about: source page, so you don't have to install
the app to see the latest content.  resource: URL's will be
broken of course.
Mitchell's suggestion: entirely replace the first "Initial Developer" bullet
point with the following text:

"Portions of this code are copyright by the Contributors to the Mozilla codebase
under the Mozilla Public License and Netscape Public License.  All Rights Reser
ved."

I would maybe suggest that "Mozilla Public License and Netscape Public License"
be shortened to "Mozilla and Netscape Public Licenses".

Presumably the phrase "Contributors" would be hyperlinked to
<http://www.mozilla.org/credits/> and "Mozilla and Netscape Public Licenses"
would be hyperlinked to <http://www.mozilla.org/MPL/>.

Don't copyright statements need a date too, e.g.
Copyright (c) 1998-2000 by the contributors ...

checked in changes dmose mentions above.
Please review, so we can iterate on this.

the problem is, we don't know what the beginning dates are for indifidual 

contributors.  for netscape, it could conceivable go back to 1994, who knows for 

other contributors.  (The mozilla site obviously started in 1998, so we know that 

date.)  So I left the date out for now.  



I'll double check with current Netscape legal to make sure this isn't a really 

bad thing.

Thanks for filing and fixing this bug. I asked for it in bug #14532 for a long
time.

Is there still the phrase "Mozilla is a commercial item"? If yes, is that
required (would be very funny)?

Also see bug #17279 "about:credits". It needs a new owner (current one is me). I
think, this is better than a direct link.
Blocks: 14532
The phrase using "commercial item" is in there because the language about the 

government needs to be copied verbatim; it's set in a statute or a reg somewhere.  

maybe eventually we can delete that entire provision (the governement used to 

take the position that unless one included this language in a license agreement, 

the government could do whatever it wanted with the software and not be subject 

to the license agreement.  or so i recall from my legal days.  But as long as the 

provision is there, the langague is set.

Fixed, per Mitchell's email to me today:
"Copyright 2000  by Contributors to the Mozilla codebase under the Mozilla 
Public License and Netscape Public
License.  All Rights Reserved." 
  
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] → [PDT+]mozilla folks to verify 02/23
verified text above in a  23 Feb 2000 build.
Status: RESOLVED → CLOSED
Need to html-ize this blurb:
In the buttom of the about: page is the U.S. GOVERNMENT END USERS notice.
In this text the hardcoded `` and the '' need to be converted into &quot;
Status: CLOSED → REOPENED
Resolution: FIXED → ---
Q: Is mozilla a registered trademark of Netscape?  And if so, 
   do we need to say that in the about: page?
fixed government blurb.
> Is mozilla a registered trademark of Netscape?

This is bug #17281. Create a dependency, if appropriate.
Created dependency on mozilla trademark bug, 17281.
Depends on: 17281
Whiteboard: [PDT+]mozilla folks to verify 02/23 → [PDT+] 2/25 email sent about mozilla trademark to btoring.
Whiteboard: [PDT+] 2/25 email sent about mozilla trademark to btoring. → [PDT+] MUST FIX: 2/25 email sent about mozilla trademark to btoring.
Marking fixed, please open specific about: bugs 
if something needs to change.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Setting QA Contact to leger to follow thru.  Waiting for mcafee to verify :-)
QA Contact: cbegle → leger
marking all, this is not a solaris bug.
OS: Solaris → All
Hardware: Sun → All
Setting QA Contact to bijals.  He will take care of reviewing the about page 
with legal.  Thanks!
QA Contact: leger → bijals
Reviewed the about page with legal for Beta 1 so we should be fine.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.