Closed Bug 27553 Opened 24 years ago Closed 22 years ago

Whine about votes on resolved bugs.

Categories

(Bugzilla :: Email Notifications, enhancement, P3)

enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: CodeMachine, Assigned: jacob)

Details

At the moment, people leave their votes on bugs that have been closed.  It would
be good if we could remind them of this periodically.  Not too much, since we
don't want to discourage use of the voting system, say every 3 months or so.

Basically the reminder should say that you have votes for a bug that has been
resolved for x amount of time.

For a resolved duplicate bug, it should say that votes aren't transferred and
why, and also how to transfer your votes to the new duplicate bug.  You might
want to handle the situation where the second bug is resolved as a duplicate of
a third bug, or some other resolution.

For all resolutions, it should explain how to remove the votes and prevent
further whines.

This could help keep the voting system vibrant, especially with all the bugs
that we've seen Slashdotted, the voters never heard from again
Resolved bugs that is, not closed.
Summary: Whine about votes on closed bugs. → Whine about votes on resolved bugs.
I don't see this as a problem.  Voters can easily reassign their votes as they 
wish.  Votes on resolved bugs don't cause any problems.
Well, this is not a problem for a person who comes to Bugzilla several times
every day. But the people who only come to Bugzilla ocasionally should be
notified when their votes are "waisted" on closed bugs.
They are, but only once.
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
> They are, but only once.
>
Not really - you are notified that the bug report is now closed, but you have to
remember that you've voted for it and not just on the CC list. There should at
least be a special message telling that you might want to update your votes now.

An even better choice would be to allow people to cast "pending" votes. The
pending vote would be counted as 0 votes, but as soon as some bug is resolved,
its vote will be transfered to the next pending vote (in the same category, of
course).
I like the pending votes idea and it would reduce the issue but would never get
rid of it, so can you file a separate bug on the idea?
I've created a bug #65801 that askes for "pending" votes or "weighted" votes.
Personally, I believe that the weighted vote is the best solution.
QA Contact: matty
Whiteboard: Future-Target
moving to real milestones...
Target Milestone: --- → Future
Moving to new Bugzilla product ...
Assignee: tara → jake
Component: Bugzilla → Email
Product: Webtools → Bugzilla
Whiteboard: Future-Target
Version: other → unspecified
Depends on: 6679
WONTFIX. There's really no need to do this. If people care about where their
votes are, they'll check the page.

Gerv
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WONTFIX
clearing target milestone on resolved non-FIXED bugs so they'll get re-triaged
if they get reopened.
Target Milestone: Future → ---
No longer depends on: 6679
I know this is old, but I just thought I'd give my threepence worth....

IMHO, votes on resolved bugs indicate that the voter disagrees with the
resolution.  To consider each possible resolution:

FIXED - I'm leaving it until I get round to downloading the latest build and
seeing it working.  Or I've just done this and found that you haven't finished
testing.
DUPLICATE - You might not be able to see the difference, but it's perfectly
clear to me!
WORKSFORME - Well, it still doesn't work for me!
INVALID - guess that would depend on what kind of invalidity it is
WONTFIX - So you don't want this feature ... but I still do!

Some of these are most likely to happen by a user who isn't sufficiently
empowered to reopen.

Personally, I tend to leave them there until it's time to liberate one to vote
on something else.

But votes on resolved bugs aren't hurting anyone, so I agree that we don't
really need email alerts or anything for them.
*** Bug 308505 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.