Last Comment Bug 6679 - Generic whining mechanism
: Generic whining mechanism
Status: VERIFIED DUPLICATE of bug 185090
:
Product: Bugzilla
Classification: Server Software
Component: Email Notifications (show other bugs)
: unspecified
: All All
: P3 enhancement with 1 vote (vote)
: ---
Assigned To: J. Paul Reed [:preed]
: default-qa
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-18 13:39 PDT by Mark Hamby
Modified: 2015-01-13 00:43 PST (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch to whine about non-NEW bugs (9.39 KB, patch)
1999-05-18 13:40 PDT, Mark Hamby
justdave: review-
Details | Diff | Splinter Review
Patch to remind for neglected bugs (4.06 KB, application/octet-stream)
2000-05-04 00:07 PDT, Klaas Freitag
justdave: review-
Details

Description Mark Hamby 1999-05-18 13:39:58 PDT
You may not want this "enhancement", but it seemed to
me that you might want to whine about ASSIGNED bugs which
have not changed.  And also about REMIND and LATER bugs.
So I expanded the concept of whining to include these.

Note: The modifications were designed to minimize the
differences between the official Bugzilla and my version.
Thus the 'whinedays' parameter was not changed to
'whinedays_new'.  And the whining was all left in 'whineatnews.pl'.
You may wish to change this if you accept the enhancement.

I have some questions about the design and operations philosophy
behind the RESOLVED REMIND and RESOLVED LATER bug states,
but will address those on the discussion group.
Comment 1 Mark Hamby 1999-05-18 13:40:59 PDT
Created attachment 210 [details] [diff] [review]
Patch to whine about non-NEW bugs
Comment 2 Terry Weissman 2000-04-13 07:34:51 PDT
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Comment 3 Mark Hamby 2000-05-03 08:21:27 PDT
Since I entered this patch/bug, our site has since disable the whining
feature of Bugzilla.  Apply this patch (or its equivalent intent) based
on Mozilla's usage (or mailing list opinion poll of other users).
Close it as WONTFIX if no one is interested.  -- Mark
Comment 4 Klaas Freitag 2000-05-04 00:07:43 PDT
Created attachment 8283 [details]
Patch to remind for neglected bugs
Comment 5 Klaas Freitag 2000-05-04 00:11:53 PDT
My attached patch (id=8283) is just another kind of whining on already assinged
bugs, which have been forgotten by the user. The amount of days, after that a
bug counts as forgotten, is user selectable through the userprefs-page (email-
settings), which is also covered by the patch.
Comment 6 Stephan Niemz 2001-02-26 13:18:35 PST
Adding default QA contact to all open Webtools/Bugzilla bugs lacking one.
Sorry for the spam.
Comment 7 Matthew Tuck [:CodeMachine] 2001-06-30 23:13:25 PDT
I'm not sure about these patches, but I'd like a generic whining mechanism in
Bugzilla.
Comment 8 Andreas Franke (gone) 2001-08-30 06:05:55 PDT
-> Bugzilla product, Email component (whinemail), reassigning.
Comment 9 Gervase Markham [:gerv] 2001-10-09 19:01:05 PDT
The author of this patch now has no interest in it; Matty has expressed interest
in a generic whining mechanism. This would seem like the sensible way to go. At
b.m.o, we seem to have found that whinemail is counter-productive anyway.

Gerv
Comment 10 Matthew Tuck [:CodeMachine] 2001-10-11 11:29:03 PDT
When it is compulsory and for the specific purpose it is currently used for, it
probably is.  Anyway, I'm sure I already reported a bug for this.
Comment 11 Dave Miller [:justdave] (justdave@bugzilla.org) 2001-10-28 01:36:06 PDT
Comment on attachment 210 [details] [diff] [review]
Patch to whine about non-NEW bugs

doesn't really fit with the direction this bug is heading, so putting 
"needs-work" to get it off the "waiting patches" list.
Comment 12 Dave Miller [:justdave] (justdave@bugzilla.org) 2001-10-28 01:36:52 PDT
Comment on attachment 8283 [details]
Patch to remind for neglected bugs

doesn't really fit with the direction this bug is heading, so putting 
"needs-work" to get it off the "waiting patches" list.
Comment 13 Matthew Tuck [:CodeMachine] 2001-10-28 01:39:46 PDT
Bug #96635 is kind of related to this.  You can see specific whine requests
hanging off that.
Comment 14 Dave Miller [:justdave] (justdave@bugzilla.org) 2002-03-31 18:59:27 PST
Changing default owner of Email Notifications component to JayPee, a.k.a.
J. Paul Reed (preed@sigkill.com).  Jake will be offline for a few months.
Comment 15 Dave Miller [:justdave] (justdave@bugzilla.org) 2003-03-11 17:57:19 PST
Bug 185090 has been filed on this same topic.  I'm going to dupe this one to
that one because it has a newer patch with more generic reporting mechanisms.
Breaking now-irrelevant dependencies, I'll put some of them back on the other bug.

*** This bug has been marked as a duplicate of 185090 ***
Comment 16 Dave Miller [:justdave] (justdave@bugzilla.org) 2003-03-29 21:48:28 PST
clearing target on DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Comment 17 Nick Bebout 2004-01-01 15:26:41 PST
v

Note You need to log in before you can comment on or make changes to this bug.