Leading spaces get an extra space in every line of the message box

RESOLVED DUPLICATE of bug 141983

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 141983
13 years ago
13 years ago

People

(Reporter: Yves Goergen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
When writing a new message, every line that begins with a space character, will
get an extra space in front of it. So
X
is
X
but
 X
becomes
  X
and
  X
becomes
   X

This way it is impossible to write only one leading space in a line. Also you
always need to remove one space from your ASCII art signature or whatever in
order to get it displayed correctly on the other end.

The problem only seems to reside in the message composition. A draft is already
stored with 2 spaces as is the message put in the Sent folder after sending it.
The source code is consistent with what is displayed then. So when composing the
message, the extra space is added in the first instance.

This problem already exists for a very long time, at least since 0.8.

Comment 1

13 years ago
Yep, it does that; it's part of how format=flowed works.  See bug 168420 for 
information about f=f, including the informative FAQ attached to that bug.

*** This bug has been marked as a duplicate of 141983 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Oh, thanks for the link. I didn't expect such a specification behind the issue.
Deactivated that flowed stuff entirely now, it seemed to be deactivated only
half (the display part) which caused the inconsistent behaviour withing the
application itself. But IMO the flowed stuff is more a pain than it was supposed
to help anything. (What should it actually help?) It requires the user to expect
this behaviour, has some interesting but broken features and might cause a
wrong/unintended display on the other side. (What clients do actually support
f=f?) I'd recommend anyone writing plaintext mails to disable this 'feature' by
default.
You need to log in before you can comment on or make changes to this bug.