Closed Bug 277274 Opened 18 years ago Closed 14 years ago

UI for RDATE support [extension fodder]

Categories

(Calendar :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cbaker, Unassigned)

References

Details

When setting up a recurring event, the user currently has the ability to add a
(negative) exception, defined here as some scheduled recurrence that should NOT
occur. It would be useful to allow positive exceptions, those unschedule
recurrence that should be associated with this item. 

For example, consider the weekly project meeting on Monday. However, on Martin
Luther King's holiday, we will not work, and therefore we will add an exception
to the recurrance to consider this. Instead of having to create a new item in
the calendar, separate from the first (such as "Group Meeting-MLK makeup"), it
would be nice to just add another exception to the list for that Tuesday.

This could be implemented in the UI simply by using the existing exceptions box,
so that an entry in the list acts as a switch: if the exception occurs on a day
when the event is scheduled to recur, then cancel that recurrence; otherwise,
schedule a recurrence for the event for that day.
Suggest this is a duplicate of bug 194556
(In reply to comment #1)
> Suggest this is a duplicate of bug 194556

Not a dupe, in my opinion.  Bug 194556 deals with modifying particular instances
of a recurring event.  For instance, if you have a meeting that occurs every
monday, but want to move it's time one particular day.  This deals with the
ability to add an extra event to a recurring set, that doesn't fit the pattern.

In the end, if this was solved, bug 194556 could then be easily fixed with the
creation of a normal exception and then a created extra exception as requested
here. Still, they are two different requests.
QA Contact: gurganbl → sunbird
Depends on: 298102
Component: Sunbird Only → General
QA Contact: sunbird → general
Summary: recurrence exceptions should include options for unscheduled recurrences → UI for RDATE support
Duplicate of this bug: 327430
I'm not quite sure we want this, being able to edit all aspects of a recurring item will make the UI overly complicated. I could imagine this happening in an extension, but if someone has an idea for UI to handle this gracefully, I'll gladly reconsider.
Keywords: uiwanted
This will definitely complicate our UI too much, but would be great as an extension.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
Summary: UI for RDATE support → UI for RDATE support [extension fodder]
You need to log in before you can comment on or make changes to this bug.