IMAP logout does not wait for answer

RESOLVED DUPLICATE of bug 115349

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 115349
13 years ago
13 years ago

People

(Reporter: Kurt Huwig, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

An IMAP logout works like this (C: client, S: server):

C:1 logout
S:* BYE LOGOUT received

Thunderbird does not wait for the answer to be received. Maybe this is a
workaround for hanging servers, but for working servers these is a log-entry
every time about the client closed the connection too early.

I would like to have Thunderbird read the 'BYE' message with a short timeout.

Reproducible: Always

Steps to Reproduce:
1. start a TCP dump
2. Connect to an IMAP server
3. close Thunderbird
Actual Results:  
Thunderbird closed the connection before the 'BYE' answer was received.

Expected Results:  
Wait at least a short time for the 'BYE' answer
(Reporter)

Comment 1

13 years ago
I forgot one line of server response:

C:1 logout
S:* BYE LOGOUT received
S:1 OK Completed

You can try this with

telnet imap-server imap

Escape character is '^]'.
* OK sloxsponts Cyrus IMAP4 v2.1.9 server ready
1 logout
* BYE LOGOUT received
1 OK Completed

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 115349 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.