Closed Bug 277754 Opened 17 years ago Closed 9 years ago

Firefox opens external links in a new window instead of a new tab as specified in Options

Categories

(Firefox :: Tabbed Browser, defect)

1.0 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: foxy, Unassigned)

Details

When click on a links in a Thunderbird or other external application, Firefox
opens them in a new window instead of a new tab, while
Tools/Options/Advanced/Tabbed Browsing/Open Link From Other Applications set on
New Tab in the Most Recent Window.
I confirm, manual fix for the moment:

Exit firefox, go to Windows explorer. Under Tools -> Folder Options -> File
Types scroll down to "[NONE] HyperText Transfer Protocol" and select it then
click on "advanced" Select "Open" and then click "edit" and uncheck the "Use
DDE" box. do the same for "HyperText Transfer Protocol with Privacy" and "File
Transfer Protocol".
(In reply to comment #1)
> I confirm, manual fix for the moment:
> 
> Exit firefox, go to Windows explorer. Under Tools -> Folder Options -> File
> Types scroll down to "[NONE] HyperText Transfer Protocol" and select it then
> click on "advanced" Select "Open" and then click "edit" and uncheck the "Use
> DDE" box. do the same for "HyperText Transfer Protocol with Privacy" and "File
> Transfer Protocol".

As I understand this solution is for Windows, not for Linux?
(In reply to comment #0)
> When click on a links in a Thunderbird or other external application, Firefox
> opens them in a new window instead of a new tab, while
> Tools/Options/Advanced/Tabbed Browsing/Open Link From Other Applications set on
> New Tab in the Most Recent Window.
Opening from Thunderbird is a dupe of bug 279164 (fixed today)

(In reply to comment #3)
> (In reply to comment #0)
> > When click on a links in a Thunderbird or other external application, Firefox
> > opens them in a new window instead of a new tab, while
> > Tools/Options/Advanced/Tabbed Browsing/Open Link From Other Applications set on
> > New Tab in the Most Recent Window.
> Opening from Thunderbird is a dupe of bug 279164 (fixed today)
> 
> 
Frankly speaking it does not look like 279164 dupe. First of all, 279164 was a
trunk's bug, while this is Firefox 1.0 Final Release. Then 279164 is about
Windows and Mac, this is about Linux. The description of the bug is completely
different. 279164 is about opening a wrong page or freezing the app using a TB
link, while this one is about opening a a link in a new window, while "a new
tab" is specified.

(In reply to comment #3)
> (In reply to comment #0)
> > When click on a links in a Thunderbird or other external application, Firefox
> > opens them in a new window instead of a new tab, while
> > Tools/Options/Advanced/Tabbed Browsing/Open Link From Other Applications set on
> > New Tab in the Most Recent Window.
> Opening from Thunderbird is a dupe of bug 279164 (fixed today)
> 
> 

(In reply to comment #3)
> > New Tab in the Most Recent Window.
> Opening from Thunderbird is a dupe of bug 279164 (fixed today)

Okay, setting one thing straight: my experience was that it was not limited to
Thunderbird links (also other external links where opening in a new window).
But the fix for bug 279164 fixed it indeed for me(ON WINDOWS).

I found this bug have many similarities and thought is was about the same bug,
this is another bug after all (branch and Linux). I'll remove my vote for this bug.

The same problem for me on Gentoo Linux using KMail and Sylpheed-Claws.


(In reply to comment #0)
> When click on a links in a Thunderbird or other external application, Firefox
> opens them in a new window instead of a new tab, while
> Tools/Options/Advanced/Tabbed Browsing/Open Link From Other Applications set on
> New Tab in the Most Recent Window.

Just wondering if this one is still open. Have you tried latest trunks and 1.0.1
release builds? What are the steps to repeat the bug? Thanks.
(In reply to comment #7)
> Just wondering if this one is still open. Have you tried latest trunks and 1.0.1
> release builds? What are the steps to repeat the bug? Thanks.

I installed 1.01 yesterday and the bug is still there. You can replicate it by
just going to google and set Prefernces to "Open search results in a new browser
window" and then trying to open the link. If you have "New tab in the most
recent window" chosen in Options, it should open the link in new tab. In my case
it always opens it in a new window. TBE solves this problem but I would rather
get rid of it. Note that the bug is only in Linux version. In Windows it works
correctly.
Thanks, I DIDN'T notice the linux only part. You should note somehow that it is
not just branch, but also trunk. The version doesn't give the option of both,
just "unspecified", which isn't correct here.

Good luck.
Exactly what is described in the summary, is happening with my Firefox 1.5 on OS/2. (Both from a link in Thunderbird ans from a URL object on the desktop.) Adding /dde doesn't seem to fix this.

If Linux isn't fixed yet, and OS/2 is affected too, should OS be set to all?
If, however, this is fixed for the Linux version, please tell, so I can create a new bug for FF1.5 on OS/2.
Not sure about Linux, but on Windows under Firefox 1.5, the path is now Tools/Options/Tabs/Open Links from other applications in: a new tab in the most recent window


Good luck.
Getting the same behaviour with Firefox 1.5 and Thunderbird 1.5 under OS/2.
Assignee: bugs → nobody
Isn't this fixed now?  Unless I am really missing what this bug is, I think this has been fixed for a little while.
WFM as of Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070528 Minefield/3.0a5pre
I'm having the reverse problem in 2.0.0.6 on osx 10.4.10: I have preferences set to open in a new window, and they're opening in tabs instead.
(In reply to comment #15)
> I'm having the reverse problem in 2.0.0.6 on osx 10.4.10: I have preferences
> set to open in a new window, and they're opening in tabs instead.

Unless we're comparing behavior between already-released versions of Firefox to in-development versions, we're usually all testing the latest nightly trunk or branch builds, the former of which can be found here:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk
I'm having the same problem with 2.0.0.11 does anyone know of a fix? I'd like to keep Firefox as my default browser so I hope there is a fix for this problem.
(In reply to comment #1)
> I confirm, manual fix for the moment:
> 
> Exit firefox, go to Windows explorer. Under Tools -> Folder Options -> File
> Types scroll down to "[NONE] HyperText Transfer Protocol" and select it then
> click on "advanced" Select "Open" and then click "edit" and uncheck the "Use
> DDE" box. do the same for "HyperText Transfer Protocol with Privacy" and "File
> Transfer Protocol".

Thanks. But this did not correct the problem.

(In reply to comment #13)
> Isn't this fixed now?  Unless I am really missing what this bug is, I think
> this has been fixed for a little while.
> 

If you know of a fix to this problem please include a link to it in your reply.

Thanks.
What's the deal on this bug? Is it for the 1.0 branch still, really? Or is this a bug which has just been missed for some reason? I think if nothing else, it needs to be brought up to date on the version info.
In Minefield, the problem is reversed: I have it set to open windows instead of tabs, but it insists on opening them in tabs anyhow.  Very annoying.
That Google test case can not be reproduced in Windows anymore for me, but like others have said here, something may still be amiss in OS/X and Linux.
I am having this bug in Mac OS X with Firefox 3.0b5 and Adobe Air applications like Twhirl. It seems OK with Apple Mail.
Still here in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

OSX 10.5.3
Appears to be working properly at the moment, tested through two different external apps using OSX 10.8.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.