Unsupported FTP server "ITRON embedded printer OS"

RESOLVED WONTFIX

Status

()

--
minor
RESOLVED WONTFIX
14 years ago
3 years ago

People

(Reporter: jconley, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
I have a Brother MFC-420CN network printer, which also doubles as an SD/MMC/etc
reader via an embedded FTP server.

When opening the printer with the URL "ftp://brn_636c8c/", I get the follwoing
message:

The FTP server 200 ITRON embedded printer OS is currently unsupported.

This works just fine in IE. Perhaps Mozilla could fall back to the most
compatible FTP standard it has or let the user choose which to use.
Guess I'll have to use IE for a few things still...
That would indicate that the printer is the one preventing you from getting it
working, not Firefox.

You can try using the User Agent Switcher Extension at
https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&id=59&vid=617
to switch your user agent to that of IE.
(Reporter)

Comment 2

14 years ago
Unforunately the User Agent switcher set to 'Internet Explorer 6' or any other
setting does not change the behavior.
I was of the opinion that, in general, FTP servers do announce a
type/name/etc... and some programs use these identifiers to determine unix/dos
ftp formats or other  nuiances. Didn't know if Firefox also used these.

Also, I would expect the message to say 'Mozilla Unsupported' as opposed to 'FTP
Server ITRON' unsupported if it actually was a problem with the User Agent.
See bug 192396 and bug 202730.
Component: File Handling → General
-> Networking:FTP

The message is from Mozilla itself and the Ua has nothing to do with this.
There is no workaorund for this because the supported FTP types are hardcoded.
Assignee: bugs → dougt
Component: General → Networking: FTP
Product: Firefox → Core
QA Contact: aebrahim-bmo → benc
Summary: Unsupported FTP server type → Unsupported FTP server "ITRON embedded printer OS"
Version: 1.0 Branch → Trunk
*** Bug 283727 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
I dont know if there is much value in adding a "me, too", but I have a Brother
MFC-620CN which exhibits the same error as described in the first posting when
using Firefox to access the media cards via ftp.  ftp using IE works fine, as
does filezilla client and command line ftp under windows.  Access from Nautilus
and terminal is fine under linux.  Firefox fails in both environments.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 8

13 years ago
Tested in Deer Park and the issue is still present. This is a very minor issue
if you have a FTP client. I would not be hurt to see this closed as "do not fix"
or deferred. Your call.

I have included a little more information below since this is still unconfirmed
and in case you decide to pursue this further.


Article describing ITRON as an embedded OS. Would expect to see in other products.
http://tronweb.super-nova.co.jp/itron.html

My printer has a bay for media cards, which it exposes via the ITRON FTP server.
 The following is the ftp client output accessing the server and pulling a file
listing from an SD card.

[Windows FTP Client Output]
ftp> open brn_636c8c
Connected to brn_636c8c.
220 FTP print service:V-1.10/Use the network password for the ID if updating.
User (brn_636c8c:(none)):
230 User  logged in.
ftp> dir
200 Ready command OK.
150 Transfer Start
total       1218
dr--r--r--   1 root     printer           0 Nov  5 10:40 MSMETADATA
dr--r--r--   1 root     printer           0 Apr 16 00:29 Program Files
dr--r--r--   1 root     printer           0 Nov  6 19:35 WMDRM
dr--r--r--   1 root     printer           0 Nov  5 16:05 My Documents
-r--r--r--   1 root     printer         296 Nov  7 09:22 WMPInfo.xml
dr--r--r--   1 root     printer           0 Mar  1 22:24 share
dr--r--r--   1 root     printer           0 Apr 16 00:29 FilesToBeDeleted
dr--r--r--   1 root     printer           0 May 11 20:21 MUSIC
226 Data Transfer OK.
ftp: 638 bytes received in 0.00Seconds 638000.00Kbytes/sec.
ftp>

[Linux FTP Client Output]
ftp> Connected to 192.168.25.96.
220 FTP print service:V-1.10/Use the network password for the ID if updating.
502 Unknown command received.
502 Unknown command received.
KERBEROS_V4 rejected as an authentication type
Name (192.168.25.96:root): 230 User root logged in.
Remote system type is ITRON.
ftp> 227 Entering Passive Mode (192,168,25,96,33,4)
150 Transfer Start
total       1218
dr--r--r--   1 root     printer           0 Nov  5 10:40 MSMETADATA
dr--r--r--   1 root     printer           0 Apr 16 00:29 Program Files
dr--r--r--   1 root     printer           0 Nov  6 19:35 WMDRM
dr--r--r--   1 root     printer           0 Nov  5 16:05 My Documents
-r--r--r--   1 root     printer         296 Nov  7 09:22 WMPInfo.xml
dr--r--r--   1 root     printer           0 Mar  1 22:24 share
dr--r--r--   1 root     printer           0 Apr 16 00:29 FilesToBeDeleted
dr--r--r--   1 root     printer           0 May 11 20:21 MUSIC
226 Data Transfer OK.
ftp> 221 Good bye.

Enjoy.
I think the issue here is the following code in nsFtpState::R_syst:

1285         else
1286         {
1287             NS_ASSERTION(0, "Server type list format unrecognized.");
1288             // Guessing causes crashes.
1289             // (Of course, the parsing code should be more robust...)

And then we throw this error.

Confirming; we should just fix the parser to be saner and then randomly pick
something for servers we don't know offhand.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
OS: Windows XP → All
Hardware: PC → All

Comment 10

13 years ago
I have just purchased a 420CN as well, and observed Firefox threw the "The FTP server 200 ITRON embedded printer OS. is currently unsupported." when reading a media card; however, IE was able to sucessfully ftp from the printer.

As per previous comment:
"Confirming; we should just fix the parser to be saner and then randomly pick
something for servers we don't know offhand."  Would be safe to conclude that this bug may be resolved in the next up coming release?
Nobody's working on this at the moment.  Hence the "helpwanted" keyword.

Comment 12

11 years ago
mass reassigning to nobody.
Assignee: dougt → nobody
only critical ftp fixes now
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.