Bugzilla product should have component@bugzilla.bugs default assignees

VERIFIED FIXED

Status

()

--
enhancement
VERIFIED FIXED
14 years ago
7 years ago

People

(Reporter: mkanat, Assigned: justdave)

Tracking

Details

(Reporter)

Description

14 years ago
Right now, most Bugzilla components are *actually* unowned, even though they say
they're owned by justdave.

Instead, we should do like Mozilla has, and have things like
installation@bugzilla.bugs. Then, people could watch certain components, and it
wouldn't look like things were actually being worked on.

Their names can still be "nobody's working on this, feel free to take it". :-)
ok, this is done with my components except for the ones I'm actively (or should
be actively) participating in.
(Reporter)

Comment 2

14 years ago
Cool! :-)

I suspect that myk will at least want to set the "UI" component to
"user-interface@bugzilla.bugs" or something like that, and maybe a few other of
his components, also...? (Myk?) :-)

I think another important thing that we should do is triage the current bugs
that are assigned to you, justdave, and re-assign them to
component@bugzilla.bugs. :-)

I think that we can probably assume that if anything is UNCONFIRMED, you are
probably not personally working on it, so we can probably mass-change those.
Status: NEW → ASSIGNED
(In reply to comment #2)

> I think another important thing that we should do is triage the current bugs
> that are assigned to you, justdave, and re-assign them to
> component@bugzilla.bugs. :-)

I will take care of that sometime after we release. :)  There are some bugs that
I intend to keep (probably not many though) and I don't want those getting lost
in the shuffle.

> I think that we can probably assume that if anything is UNCONFIRMED, you are
> probably not personally working on it, so we can probably mass-change those.

That's probably a safe assumption.
(Reporter)

Comment 4

14 years ago
From the developers list:

"Right. You can do this for all my components except UI as well, since I
haven't been strongly owning the others for a while now.

-myk"
OK, Myk's are done.  The only other components I see that this should probably
be done to are Zach's.... 

Comment 6

14 years ago
Generally, I'm not a big fan of using component@bugzilla.bugs type owners since
it eliminates any sense of ownership at all. On the whole, I think some
ownership is better then no ownership, no matter what form it takes. While I
clearly have not been much of an owner in recent times, that's a subject for an
upcoming blog post and I'll address that as a separate issue. 

That being said, if you want to do my components, feel free. 
(Reporter)

Comment 7

14 years ago
zach -- I'd like checksetup to have an installation@bugzilla.bugs assignee, so
that I could watch it and you could also watch it. Then we could take the bugs
that we were actually going to work on. There could be basically two default
assignees instead of one, basically.
This is done for the components that it applies to.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 9

14 years ago
Administration   	 administration@bugzilla.bugs
Attachments & Requests 	attach-and-request@bugzilla.bugs
Bug Import/Export & Moving 	import-export@bugzilla.bugs
Bugzilla-General 	general@bugzilla.bugs
Creating/Changing Bugs 	create-and-change@bugzilla.bugs
Documentation 	documentation@bugzilla.bugs
Email Notifications 	email-notifications@bugzilla.bugs
Installation & Upgrading 	installation@bugzilla.bugs
Query/Bug List 	query-and-buglist@bugzilla.bugs
Reporting/Charting 	gerv@mozilla.org
User Accounts 	user-accounts@bugzilla.bugs
Status: RESOLVED → VERIFIED

Comment 10

14 years ago
eep, gerv isn't a generic :)
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.