Thunderbird can nuke local folder contents when you move them around

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: gerv, Assigned: mscott)

Tracking

({dataloss})

Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [asaP1])

OK, I have a reproduction scenario for this one, which has just caused the loss
of six months worth of spam archives - or would have, if I hadn't wised up since
I got hit by bug 278411, and made backups. And yes, it's only spam, but I also
moved a load of really important data at the same time. Fortunately, that didn't
get nuked; and the difference between the two showed me where the bug is.

- Create a folder under Local Folders called "Test"
- Put some messages in it
- Confirm in your profile folder that the relevant file ("Test") has non-zero 
  size
- Rename the folder to "Test1"
- (Note that Test.sbd remains in your profile folder; this may be relevant)
- Create a new folder called "Test"
- Move Test1 into Test
- The messages in Test1 are now lost, and the Test1 file has zero size (although 
  Test1.msf has non-zero size)
- Delete the folder Test1
- Attempt to delete the folder Test - it won't delete

Oh dear :-(

Gerv

Comment 1

15 years ago
I just lost a complete folder of mails (with several sub-folders). I move the
folder (a sub-folder of 'Local Mail') to 'Inbox' of 'Local Mail'.
It worked fine, but after I closed Thunderbird and re-launched it later the
folder was nuked.

This has happened at least once before (might have been on 0.8, too), but it
doesn't happen all the time. 

Haven't been able to reproduce it yet.

Any fixes available? - very annoying bug, lost fairly important data.

Andy
Requesting blocking-aviary-1.1. This is a fairly serious dataloss bug - you can
lose entire trees of folders.

Gerv
Flags: blocking-aviary1.1?
Dup of Bug 65303, which is written in "Known Issues" section of Mozilla's
"Release Notes" of almost all Mozilla's releases.
See Bug 65303 comment #30.
I don't know why Thunderbird's "Release Notes" try to hide this old and popular
and annoying bug...
Just encountered the same problem. Lost a whole subtree of my mail folders with
56000 mails in it. I hoped I could replace OutlookExpress but I guess I have to
wait for a while :-(

Comment 5

14 years ago
I would like to add that in my experience, the user does not need to move the
folders. Thunderbird itself can sometimes move the folders without the user
trying to move them, and then data loss ensues. An extremely serious bug for a
program meant to keep data.  :-(

Updated

14 years ago
Whiteboard: [asaP1]

Comment 6

14 years ago
Similar to comment #1, I moved a subfolder of Local Mail (year and a half of archived email) to the Inbox 
of Local Mail, it was nuked in similar fashion. Thunderbird 1.02. grepping all of the files in the Mail folder 
reveals no trace of the emails.

Comment 7

14 years ago
Some of my users have up to 3 gigabytes of data in their local folders. So our
Thunderbird deployment will be compromised if some of them lose their data.

This is a first importance bug; it should be fixed before any enterprise deployment.

Thanks to TB dev' team to try fixing it in version 1.1

Comment 8

14 years ago
I don't know if what I experienced is the same problem, but when my folders were
detected by Symantec AntiVirus to contain infected files (it turns out some
spams that I'd deleted contained infected attachments), Symantec quarantined
some of my mail files (not necessarily folders), and when I tried to restore
them some of my older mails got lost. Opening these files in a notepad
equivalent showed that at least some of the older messages still exist but don't
display in TB, altho many are definitely lost.

Comment 9

14 years ago
Hi,

I have also been hit by the same bug, loosing all my job related mails.
Any way to retrive............

Rohit

Comment 10

14 years ago
I believe Gerv's bug is a dup of a bug I just fixed on the trunk - bug 65303.
I'm not convinced the rest of the comments refer to the same bug.

Comment 11

14 years ago
I have been hit by a similar bug. My workflow is somewhat different from those
mentioned before. I posted an indepth workflow on the mozilla Thunderbird bugs
forums:

http://forums.mozillazine.org/viewtopic.php?t=289139

Comment 12

14 years ago
lunyee, can you reproduce this with a recent trunk build, from when after bug
65303 was fixed (after 6/30/2005)?

Comment 13

14 years ago
Hm. Sorry I'm not familiar at all with setting up a trunk build. I was running
1.0.2. Is there a page of some sort that describes how I can get a trunk build
up and running? That said, it does bear some semblance to that bug 65303, except
with the implications of data loss in my case rather than a crash.

Comment 15

14 years ago
(In reply to comment #14)
> ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk
> 
> will give you the latest trunk build.

Perfect thanks. I'll see what I can do.

Comment 16

14 years ago
Hrm. I must have been on crack on Friday. Gerv's workflow is identical to mine.
I have yet to test this workflow out on the latest trunk yet. I'm a bit busy at
the moment.

Updated

14 years ago
Flags: blocking1.8b4?

Comment 17

14 years ago
one of my clients was hit by this bug a couple weeks ago while using 1.0.2.
we'd need to get this for b4 if it's gonna make the release train.
Flags: blocking-aviary1.5?
Assignee

Comment 19

14 years ago
Minusing due to the fact that we actually believe we fixed the issue Gerv
originally reported as part of Bug 65303 which is in 1.1/1.8b4.
Flags: blocking1.8b4? → blocking1.8b4-

Comment 20

14 years ago
I can reproduce this bug too!  Dangerous to my data.  Is this bug also in the
Suite, or just Thunderbird?

Comment 21

14 years ago
I can reproduce this bug too!  Dangerous to my data.  Is this bug also in the
Suite, or just Thunderbird?

Thunderbird version 1.0.6 (20050716)
Win XP home

Comment 22

14 years ago
Looks like it's fixed!  I just installed the 2005-08-10 nightly and the bug can
no longer be reproduced on that build.  Thanks.

Comment 23

14 years ago
I was hit by this bug, too (Thunderbird 1.0.7, 20050923). So it does not seem to be fixed in the 20050810 version.

Used extensions (at the time I encoutered the bug):
- Enigmail 0.93.0
- Mozilla Calendar 0.8.3+
- Mnenhy 0.7.2
- QuickNote 0.6.0.2

Comment 24

14 years ago
(In reply to comment #23)
> I was hit by this bug, too (Thunderbird 1.0.7, 20050923). So it does not seem
> to be fixed in the 20050810 version.
> 

It was probably fixed in a nightly build of the upcoming Thunderbird 1.5.
QA Contact: front-end
closing WFM per comment 21. Please reopen if you disagree based on current trunk build
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0
You need to log in before you can comment on or make changes to this bug.