cite attribute of blockquote misses colon in URL

VERIFIED FIXED in mozilla1.8.1

Status

VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: BenB, Assigned: mkmelin)

Tracking

({fixed1.8.1})

Trunk
mozilla1.8.1
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Reproduction:
1. Reply to mail using HTML editor, with quote, send as HTML
2. Look at source code of sent msg

Actual result:
<blockquote cite="mida3d199f004123010006f9935cf@mail.gmail.com"
 type="cite">

Expected result:
<blockquote cite="mid:a3d199f004123010006f9935cf@mail.gmail.com"
 type="cite">
(Reporter)

Comment 1

14 years ago
hm, I have no idea where that even comes from. I thought it's from mimetpla.cpp,
but I can't see any cite attribute being added there (only type="cite", which is
something else).

Comment 2

14 years ago
nsHTMLEditor::InsertAsCitedQuotation inserts the cite string
(cite="blahblah"):http://lxr.mozilla.org/seamonkey/source/editor/libeditor/html/nsHTMLDataTransfer.cpp#2342
But the cite string (the thing with the mid:) is passed in to that routine.
Looks like it's mCiteReference in nsMsgCompose::ConvertAndLoadComposeWindow:
http://lxr.mozilla.org/seamonkey/source/mailnews/compose/src/nsMsgCompose.cpp#509

The mid: may come from here:
http://lxr.mozilla.org/seamonkey/source/mailnews/compose/src/nsMsgCompose.cpp#1795
or it might already be in myGetter.  I don't know that code, but that's probably
the place to start looking.
(Assignee)

Comment 3

12 years ago
*** Bug 185562 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

12 years ago
Yeah, originally it was "mid:", but it seems the colon accidentially got removed in bug 109179. 

I have a patch to make us follow rfc 2111 again.
(Assignee)

Comment 5

12 years ago
Created attachment 241344 [details] [diff] [review]
proposed fix: add back the colon for mid:

Add back the colon in the ULR, so we get mid:messageid, not midmessageid in blockquote href.
Assignee: ben.bucksch → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #241344 - Flags: superreview?
Attachment #241344 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #241344 - Flags: superreview?(bienvenu)
Attachment #241344 - Flags: superreview?
Attachment #241344 - Flags: review?(bienvenu)
Attachment #241344 - Flags: review?

Comment 6

12 years ago
Comment on attachment 241344 [details] [diff] [review]
proposed fix: add back the colon for mid:

thx
Attachment #241344 - Flags: superreview?(bienvenu)
Attachment #241344 - Flags: superreview+
Attachment #241344 - Flags: review?(bienvenu)
Attachment #241344 - Flags: review+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed]
mozilla/mailnews/compose/src/nsMsgCompose.cpp 	1.495
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → mozilla1.9alpha

Comment 8

12 years ago
Comment on attachment 241344 [details] [diff] [review]
proposed fix: add back the colon for mid:

This is a small, simple, and useful patch.  I'll ask for 1.8.1, and if denied, I'll ask for 1.8.1.1.
Attachment #241344 - Flags: approval1.8.1?
Comment on attachment 241344 [details] [diff] [review]
proposed fix: add back the colon for mid:

a=beltzner on behalf of drivers for the 1.8.1 branch (mailnews only)
Attachment #241344 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed (1.8 branch)]
mozilla/mailnews/compose/src/nsMsgCompose.cpp 	1.460.2.24
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
Target Milestone: mozilla1.9alpha → mozilla1.8.1

Comment 11

12 years ago
V fixed with TB 2b1-1018.
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.