DNS Round-Robin Load Balancing Broken

RESOLVED DUPLICATE of bug 171195

Status

()

RESOLVED DUPLICATE of bug 171195
14 years ago
14 years ago

People

(Reporter: msiemens, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Firefox doesn't appear to correctly handle web sites that are setup to use DNS
load balancing.

I've set up two web servers using DNS round-robin load balancing.  The IP
address of each server points to the DNS name www.foobar.com.

When Firefox connects to www.foobar.com, it appears to only grab one of the IP
addresses associated with www.foobar.com.  If I shutdown the web server to which
Firefox is connecting, I receive the error message "The connection was refused
when attempting to contact www.foobar.com."  Instead of using www.foobar.com's
second IP address, like other browsers, Firefox isn't happy until the stopped
web server is started up again.

This problem also seems to be present in Netscape 7 and Mozilla 1.2.1 according
to this bug:  https://bugzilla.mozilla.org/show_bug.cgi?id=171195

Reproducible: Always

Steps to Reproduce:

*** This bug has been marked as a duplicate of 171195 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
After further testing, everything appears to work as it should.  My problem was a result of testing over a 
VPN connection, which was causing the odd results.
You need to log in before you can comment on or make changes to this bug.