Closed Bug 171195 Opened 18 years ago Closed 10 years ago

DNS round robin and the DNS Cache

Categories

(Core :: Networking, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 392953

People

(Reporter: dave.banthorpe, Unassigned)

References

Details

Currently running Netscape 7 on Windows 2000.

I am observing bad behaviour from the browser with DNS round robin. I have 2 
web servers load balanced using round robin.

I connect to the load balanced web site OK.

I then kill one of the web servers.

I then refresh the browser.

It tells me it failed to connect to the server.

Now the netlib documentation states:
If at any point during a connection, the ip address currently in use for a 
host name fails, netlib will use the next ip address stored in the host entity.

So why does it not try the other IP address which is working?
In addition, I have tested by removing the dead server DNS entry and set the 
TTL of the round robin records to 1 second. I have also set the 
dnsCacheExpiration time to 0 second (i.e. disabled). Even then, Netscape 
responds with "the connection was refused when attempting to contact xxxx". 

If the DNS cache is disabled, why does Netscape not requery DNS? It seems to 
be using a stale record somewhere.
a) This has absolutely nothing to do with Bugzilla, moving to the Browser product.

b) Netscape, although based on Mozilla, is not Mozilla.  Resolving INVALID as
soon as the product move completes.  Please contact Netscape's tech support with
this issue.
Assignee: justdave → asa
Component: Bugzilla-General → Browser-General
Product: Bugzilla → Browser
QA Contact: matty → asa
Version: unspecified → other
Netscape issues belong at http://help.netscape.com
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
I've installed a new W2K box and downloaded Mozilla v1.0.1. This is behaving 
in the same way. 

Problem statement:

I installed Mozilla v1.0.1 and added the following line to my prefs.js file:

user_pref("network.dnsCacheExpiration", 0);

as I do not want Mozilla to cache any DNS, thereby forcing it to use the local 
workstation's OS DNS cache.

1 have 2 web servers, DNS round robin'd to nfuse.asp.com so there a 2 entries 
in DNS for nfuse.asp.com (172.16.10.1 and 172.16.10.2). 
I stop the web services on server 2 and remove the entry for 172.16.10.2 from 
DNS for nfuse.asp.com
I connect to http://nfuse.asp.com with Mozilla and I am immediately connected 
to server 1 (172.16.10.1).
I then stop server 1 and restart server 2.
I change the round robin entry to point only to server 2.
I then refresh Mozilla and I get the following message "The connection was 
refused when attempting to connect to nfuse.asp.com".

So it looks like the entry in prefs.js is either being ignored, overridden or 
not working!

-Dave
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I've just tried adding the following setting which also has not effect:

user_pref("network.dnsCacheEntries", 32);

Any new on this one yet?
You should really report the issue at Netscape ! This doesn't belong in Mozilla,
which is a different product (although Netscape 7 is based on Mozilla).

BTW: dnsCacheExpiration isn't implemented in Mozilla. See bug 168566. Read also
bug 162871 .
I don't really care about the dnsCacheExpiration - that was just a try at 
fixing it. I'd rather use Mozilla if I can instead of Netscape so I'd like to 
get the dnsCacheTimeout working in Mozilla.
I have verified this same bug in Mozilla-1.2.1 today.

I have 2 webservers attached to the same DNS name.

When I go to the common name, everything works fine and Mozilla stays with the 
IP address that it first picks up.  If I shut down that server, Mozilla only 
gives a "connection refused" type message and does not try the other address.
that's bug 162871 you're reporting
Product: Browser → Seamonkey
Assignee: asa → darin
Status: REOPENED → NEW
Component: General → Networking: HTTP
Product: Mozilla Application Suite → Core
QA Contact: asa → networking.http
*** Bug 278753 has been marked as a duplicate of this bug. ***
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking
At the request of Wayne Mery, I tried to duplicate this bug, and it appears to be fixed.

I configured my DNS to have two addresses for my website.  I went to the website with Firefox, verifying (with tcpdump) that clicking around the site keeps me on the same host.  I then stopped apache2 on the host that Firefox was using, and saw connections switch over to the second host.

The version information for my browser is:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071004 Iceweasel/2.0.0.8 (Debian-2.0.0.8-1)

Status: NEW → RESOLVED
Closed: 18 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392953
You need to log in before you can comment on or make changes to this bug.